php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30824 Missing export function in php5ts.dll with PDO
Submitted: 2004-11-18 14:59 UTC Modified: 2010-12-29 14:17 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: programmer at bardware dot de Assigned: wez (profile)
Status: Closed Package: PDO related
PHP Version: 5CVS-2004-11-18 (dev) OS: Win2k
Private report: No CVE-ID: None
 [2004-11-18 14:59 UTC] programmer at bardware dot de
Description:
------------
Hi,

I wanted to try the new PDO libraries. They didn't work with PHP 5.0.2 stable at all because some ap_php_snprintf function was missing in php5ts.dll.
They kind of worked with PHP 5.0.3-dev (php5.0-win32-200411180930.zip). They in fact crashed when I tried to prepare a statement for execution, but the php5ts.dll exported all needed functions.
I now read PDO extensions are designed to work with PHP 5.1
I got php5-win32-200411181130.zip set it up and tried to run a sample. PHP did not startup with PDO because _zval_copy_ctor function is not exported from php5ts.dll.
According do what I see with Microsoft's "depends"-tool It is exported from php5ts.dll in version 5.0.3-dev.

Best
Bernhard


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-05 22:20 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

It have been fixed by Frank long time ago.
 [2005-04-14 12:13 UTC] programmer at bardware dot de
The PHP5ts.dll in Download: php5.0-win32-200504140830.zip  does (again) not export _zval_copy_ctor although it is required by php_pdo.dll available from http://snaps.php.net/win32/PECL_5_0/ with a date of: 14-Apr-2005 10:55    
According to what I understand does the PECL_5_0-directory provides downloads for PHP 5.0.x whereas PECL_UNSTABLE provides downloads for PHP 5.1.x

PDO-downloads in "unstable" dir are dated: 17-Feb-2005 04:42  
The php_pdo.dll imports _zval_copy_ctor_func which again is not exported from php5ts.dll in php5-win32-200504140630.zip (current 5.1-dev) but exists in current 5.0-dev.
 [2005-04-14 16:29 UTC] wez@php.net
"unstable" downloads bundle the PDO .dll

Both stable and unstable branches do, in fact, export the right functions (at least, the code says it does).   Please check very carefully to make sure you are using the right DLLs.
 [2010-12-29 14:17 UTC] jani@php.net
-Package: PECL related +Package: PDO related
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 05:03:38 2021 UTC