php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30817 @ php-include, im LETZTEN Beitrag nicht "$page" aufgef?hrt
Submitted: 2004-11-17 20:55 UTC Modified: 2004-11-18 00:21 UTC
From: aurormiteinemohr at gmx dot net Assigned:
Status: Not a bug Package: Website problem
PHP Version: 5.0.1 OS: windows
Private report: No CVE-ID: None
 [2004-11-17 20:55 UTC] aurormiteinemohr at gmx dot net
Description:
------------
im letzten beitrag ist nicht $page aufgef?hrt, owbwohl es f?r $filename nat?rlich ben?tigt wird, da diese ja folgenderweise definiert ist ...:   $filename = $path.$page.$extension;

Reproduce code:
---------------
<?php
  $path = 'http://tunichtgut.s01.user-portal.com/';
  $extension = '.php';
 
  if ( preg_match("#^[a-z0-9_]+$#i",$page) ){
   $filename = $path.$page.$extension;
   include($navi);
  }
?>

Expected result:
----------------
include file wird nicht angezeigt

Actual result:
--------------
include file wird nicht angezeigt

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-18 00:21 UTC] goba@php.net
This is not a php.net website problem. Please ask support questions at php-general@lists.php.net (in English), or try to find some German support options at http://php.net/support and http://php.net/mailing-lists
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 02:03:33 2022 UTC