php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30750 When /var/tmp was deleted, File Uploads break with no error messages
Submitted: 2004-11-10 20:41 UTC Modified: 2004-11-11 01:40 UTC
From: gnarf at gnarf dot net Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 4.3.9 OS: FreeBSD 4.8
Private report: No CVE-ID:
 [2004-11-10 20:41 UTC] gnarf at gnarf dot net
Description:
------------
/var/tmp was somehow deleted on my machine.  Which is 
the root of this problem, however file uploading got 
completely broken... _FILES had no data in it although 
the file was being uploaded just fine.  I wouldn't 
expect the file uploading to work when the tmp directory 
was missing, however, there were no error messages or 
anything to elude to what the problem was.

Reproduce code:
---------------
<? 
  print_r($_FILES);
?>
<form enctype="multipart/form-data" method=POST>
<input type=file name="file">
</form>

Expected result:
----------------
You would expect to see the files information...

Actual result:
--------------
$_FILES was empty...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-11 01:40 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC