php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #3074 allow: foreach ($array as $key => &$val) in zend (byref)
Submitted: 1999-12-31 08:36 UTC Modified: 2003-02-18 11:48 UTC
Votes:4
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: thies at digicol dot de Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0 Latest CVS ( OS: all
Private report: No CVE-ID: None
 [1999-12-31 08:36 UTC] thies at digicol dot de
as discussed on the ML - just that so that we don't forget.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-31 22:23 UTC] waldschrott@php.net
I think it happend. You did forget! ;)
Results in a parse error.
 [2001-05-19 17:25 UTC] jeroen@php.net
Just a reminder... seems to be forgotten again :)

Come on... this can't be that hard? Or is it?
 [2001-05-19 17:40 UTC] jeroen@php.net
From line 117 of zend_operators.c it says: If the string is nor an exact double, nor an exact long, do strtol on it.

There you should first try strtod, see if it parses more chars that strtol...

And I don't know anything about C!
 [2002-02-24 07:26 UTC] sander@php.net
Dupe of 15663... 
 [2003-02-18 11:48 UTC] sniper@php.net
Place any comments to bug #15663

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 21:03:37 2021 UTC