php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30604 make install in production
Submitted: 2004-10-28 20:56 UTC Modified: 2004-10-28 21:32 UTC
From: venkatesh_babu at yahoo dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5CVS-2004-10-28 (dev) OS: AIX 5
Private report: No CVE-ID: None
 [2004-10-28 20:56 UTC] venkatesh_babu at yahoo dot com
Description:
------------
i have development and production systems (AIX 5). when i compile and install the code in development, it works fine. when i try to install that code in production i am getting error.

in production i am copying all the compiled code and 
cd php5-200409281430
#make install
/bin/sh /php5-200409281430/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/standard/ -I/php5-200409281430/ext/standard/ -DPHP_ATOM_INC -I/php5-200409281430/include -I/php5-200409281430/main -I/php5-200409281430 -I/php5-200409281430/Zend -I/usr/local/include/libxml2 -I/usr/local/opt/oracle/product/tnac01p/rdbms/public -I/usr/local/opt/oracle/product/tnac01p/rdbms/demo -I/usr/local/opt/oracle/product/tnac01p/plsql/public  -I/php5-200409281430/TSRM    -prefer-pic -c /php5-200409281430/ext/standard/info.c -o ext/standard/info.lo 
/php5-200409281430/libtool[861]: cc:  not found
make: 1254-004 The error code from the last command is 1.

what should i have to do.

Reproduce code:
---------------
/bin/sh /php5-200409281430/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/standard/ -I/php5-200409281430/ext/standard/ -DPHP_ATOM_INC -I/php5-200409281430/include -I/php5-200409281430/main -I/php5-200409281430 -I/php5-200409281430/Zend -I/usr/local/include/libxml2 -I/usr/local/opt/oracle/product/tnac01p/rdbms/public -I/usr/local/opt/oracle/product/tnac01p/rdbms/demo -I/usr/local/opt/oracle/product/tnac01p/plsql/public  -I/php5-200409281430/TSRM    -prefer-pic -c /php5-200409281430/ext/standard/info.c -o ext/standard/info.lo 
/php5-200409281430/libtool[861]: cc:  not found
make: 1254-004 The error code from the last command is 1.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-28 21:32 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 22:01:26 2020 UTC