php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30571 Imap2004a crashed apache
Submitted: 2004-10-26 22:28 UTC Modified: 2005-01-18 01:00 UTC
Votes:5
Avg. Score:3.0 ± 0.0
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: bo at theaddedones dot com Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 4.3.9 OS: Fedora 1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-10-26 22:28 UTC] bo at theaddedones dot com
Description:
------------
the general problem was an odd one when using the HORDE-IMP pacakge.  For certain messages (those with multi-parts i.e. a 'text' and an 'enriched' type).  The attempting to access the message results in a apache SegFault...  after 'downgrading' to IMAP-2002e the bug went away.


-- my compile bits --
./configure  --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --with-dom --with-dom-xslt --with-dom-exslt --enable-exif --enable-ftp --with-gd --with-png-dir=/usr --without-xpm --with-gettext --with-imap --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-mcrypt --with-mhash --enable-magic-quotes --with-mysql=/usr --with-openssl --enable-discard-path --with-pear --with-pspell --enable-xslt --with-xslt-sablot --enable-sockets --enable-track-vars --with-ttf --enable-versioning --enable-wddx --with-xmlrpc --with-zip --with-zlib --with-readline --with-iconv --with-openssl --with-freetype-dir=/usr --with-gdbm

Reproduce code:
---------------
use the Horde-Imp mail program...and attempt to read a message (i.e. like the ones sent from the OSX Mail programm where there are 2 parts a flat text and an enriched)


Actual result:
--------------
---- gdb trace ---

#0  0x00a0224c in _php_imap_add_body (arg=0x9bcbc5c, body=0x703c2065)
    at /home/cpapachebuild/buildapache/php-4.3.9/ext/imap/php_imap.c:3817
3817            if (body->type <= TYPEMAX) {
(gdb) bt
#0  0x00a0224c in _php_imap_add_body (arg=0x9bcbc5c, body=0x703c2065)
    at /home/cpapachebuild/buildapache/php-4.3.9/ext/imap/php_imap.c:3817
#1  0x00a0268b in _php_imap_add_body (arg=0x9bcbc9c, body=0x9bd06f8)
    at /home/cpapachebuild/buildapache/php-4.3.9/ext/imap/php_imap.c:3911
#2  0x009facd8 in zif_imap_fetchstructure (ht=3, return_value=0x9bcbc9c, this_ptr=0x0, 
    return_value_used=1) at /home/cpapachebuild/buildapache/php-4.3.9/ext/imap/php_imap.c:1753
#3  0x00f9c892 in get_module ()
   from /usr/local/Zend/lib/Optimizer-2.5.5/php-4.3.x/ZendOptimizer.so


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-27 18:47 UTC] iliaa@php.net
Please supply the complete message body that is causing this problem.
 [2004-10-28 21:31 UTC] bo at theaddedones dot com
--- here is a message the causes a server crash 
--- NOTE:: it did not cause a crash 100% of the time
---  but more often then not...

----SNIP---
From XXX@XXX.com Tue Oct 26 08:13:05 2004
In-Reply-To: <E543319C-275E-11D9-83C7-000A95BB151A@menzelphoto.com>
References: <0D5644E4-275D-11D9-83C7-000A95BB151A@menzelphoto.com> <35E3F400-275E-11D9-8D14-000A9579B31C@pictopia.com> <E543319C-275E-11D9-83C7-000A95BB151A@menzelphoto.com>
Mime-Version: 1.0 (Apple Message framework v619)
Content-Type: multipart/alternative;
	boundary=Apple-Mail-8-237301148
Message-Id: <895992C7-2761-11D9-8D14-000A9579B31C@pictopia.com>
Cc: XXXX <XXX@XXX.com>,
 XXXX <XXX@XXX1.com>
 XXXX <XXX@XXX2.com>,
 XXXX <XXX@XXX3.com>,
 XXXX <XXX@XXX4.com>
From: XXXX <XXX@XXX5.com>
Subject: XXXXX
Date: Tue, 26 Oct 2004 08:13:05 -0700
To: "XXXXX" <XXXX@XXXXXX>




--Apple-Mail-8-237301148
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=ISO-8859-1;
	format=flowed

hi again

i think i may have 'caught' the problem.  But this a 'guess' on my part=20=

(all be it an educated one) so it still could 'break' again

i'll be watching it through most of the day to see if it fails again...

if you notice other places of failure let me know

bo


On Oct 26, 2004, at 7:54 AM, XXXXX wrote:

> What is the "it" in your first sentence. can you actually see=20
> something occurring or not occurring? Napanet took a look at the=20
> message we were getting yesterday and said it's a "horde" issue=20
> (whatever that means). I know I've seen that word on the webmail=20
> panel.
> fda
> On Oct 26, 2004, at 7:49 AM, XXXX wrote:
>
>> hmm
>>
>> i report that it happened 3 times in the past hour
>>
>> anyhoo, should be 'temporarily' okay now (i'm still trying to figure=20=

>> out why it happens)
>>
>> bo
>>
>> On Oct 26, 2004, at 7:40 AM, XXXXX wrote:
>>
>>> well, we're still in trouble here
>>>
>>> Begin forwarded message:
>>>
>>>> From: XXX@XXXXX
>>>> Date: October 26, 2004 7:35:31 AM PDT
>>>> To: XXX@XXXXX
>>>> Cc: XXX@XXXXX
>>>> Subject: XXXXX
>>>>
>>>> Goodmorning,
>>>>  =A0
>>>> Yesterday I could not open e-mails from menzelphoto.com, it would=20=

>>>> "boot" me out, I also could not reply to client e-mails.
>>>> =A0
>>>> Today I am unable to open client e-mails as well, I receive the=20
>>>> same "web browser" message.
>>>> =A0
>>>> Liddy received the same message yesterday while in the studio=20
>>>> account trying to open menzelphoto.com e-mails, now EVERY e-mail is=20=

>>>> doing the samething.
>>>> =A0
>>>> I will be home until 10:30am this morning and then after 4:30pm,=20
>>>> I'll call Liddy after 9am to see if there is anything I can do on=20=

>>>> my end.
>>>> =A0
>>>> Thanks!
>>>> =A0
>>>> Col
>>>>
>>> XXXX
>>>
>>>
> XXXX
>

--Apple-Mail-8-237301148
Content-Transfer-Encoding: quoted-printable
Content-Type: text/enriched;
	charset=ISO-8859-1

hi again


i think i may have 'caught' the problem.  But this a 'guess' on my
part (all be it an educated one) so it still could 'break' again


i'll be watching it through most of the day to see if it fails again...


if you notice other places of failure let me know


bo



On Oct 26, 2004, at 7:54 AM, XXXX wrote:


<excerpt>What is the "it" in your first sentence. can you actually see
something occurring or not occurring? Napanet took a look at the
message we were getting yesterday and said it's a "horde" issue
(whatever that means). I know I've seen that word on the webmail panel.

fda

On Oct 26, 2004, at 7:49 AM, XXXX wrote:


<excerpt>hmm


i report that it happened 3 times in the past hour


anyhoo, should be 'temporarily' okay now (i'm still trying to figure
out why it happens)


bo


On Oct 26, 2004, at 7:40 AM, XXXX wrote:


<excerpt>well, we're still in trouble here


Begin forwarded message:


<excerpt><bold><color><param>0000,0000,0000</param>From:
</color></bold>xxx@xxxx <<xxx@xxxx>

<bold><color><param>0000,0000,0000</param>Date: </color></bold>October
26, 2004 7:35:31 AM PDT

<bold><color><param>0000,0000,0000</param>To:
</color></bold>xxx@xxxx

<bold><color><param>0000,0000,0000</param>Cc:
</color></bold>xxx@xxxx

<bold><color><param>0000,0000,0000</param>Subject: </color>Col's
neo-mail

</bold>

Goodmorning,

 =A0

Yesterday I could not open e-mails from XXXX, it would
"boot" me out, I also could not reply to client e-mails.

=A0

Today I am unable to open client e-mails as well, I receive the same
"web browser" message.

=A0

Liddy received the same message yesterday while in the studio account
trying to open menzelphoto.com e-mails, now EVERY e-mail is doing the
samething.

=A0

I will be home until 10:30am this morning and then after 4:30pm, I'll
call Liddy after 9am to see if there is anything I can do on my end.

=A0

Thanks!

=A0

Col


</excerpt>xxxxx





</excerpt></excerpt>xxxxxx




</excerpt>=

--Apple-Mail-8-237301148--
 [2005-01-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 21 17:01:23 2020 UTC