php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30548 Random parse errors with --enable-zend-multibyte
Submitted: 2004-10-24 18:46 UTC Modified: 2005-01-13 17:06 UTC
Votes:8
Avg. Score:4.1 ± 1.2
Reproduced:5 of 8 (62.5%)
Same Version:3 (60.0%)
Same OS:2 (40.0%)
From: stian at grytoyr dot net Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 5CVS-2004-10-24 (dev) OS: SuSE Linux Professional 9.1
Private report: No CVE-ID: None
 [2004-10-24 18:46 UTC] stian at grytoyr dot net
Description:
------------
Apache2 2.0.49-27.16 SuSE stock release.
Latest PHP 5.1 snapshot, compiled as follows:

./configure --with-mysql=/usr/local/mysql --with-xsl --with-apxs2=/usr/sbin/apxs2 --with-gd --with-openssl --with-freetype2 --with-postgres --with-zlib --enable-zend-multibyte

Since I need to support UTF8 semi-natively, I have compiled PHP with --enable-zend-multibyte. Most of the time, it seems to work ok, but every once in a while, I get random parse errors, for example like this:

Parse error: parse error, unexpected ',' in /srv/www/klara/webdocs/index.php on line 25

Reloading the page usually makes the error message go away, but sometimes it will show a couple of other random error messages first. Note that there is no editing going on between reloads, these errors really are bogus and random.

I'm pretty sure this is related to the Zend multibyte support, because the code was copied from a site which has run it without problems for months, but without Zend multibyte support. 

I can't really post any code to reproduce this, since it appears only sporadically and on random pages (at least I haven't been able to determine a pattern). But let me know if there is something I can provide to make this easier to debug, and I'll do my best.

The latest snapshot seems to produce fewer errors than 5.0.2, but I can't produce any numbers. It's just a gut feeling. 

Expected result:
----------------
The page should display normally.

Actual result:
--------------
Various bogus parse errors.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-28 12:01 UTC] stian at grytoyr dot net
After re-compiling without --enable-zend-multibyte, and running the site with exactly the same code for a few days, the bug has not appeared once. This seems to confirm that it is related to the multibyte support.

I might also add that the bug is present on two different machines with similar configurations.
 [2005-01-13 17:06 UTC] tony2001@php.net
Duplicate of #30213.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 08:01:28 2024 UTC