php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30458 glob() overlooks broken symlinks
Submitted: 2004-10-16 17:18 UTC Modified: 2004-10-19 22:58 UTC
From: spam at ww981 dot net Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.0.2 OS: Linux
Private report: No CVE-ID: None
 [2004-10-16 17:18 UTC] spam at ww981 dot net
Description:
------------
 If a symlink doesn't point to a existing file/dir, glob
overlooks it. I'm pretty sure this is a bug because glob
should return everything existing in the pattern. glob in
php 4.3.9 has the same bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-19 22:58 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

It is a bug in libc which implements glob(). PHP simply returns what the libc functions returns.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 03:01:23 2020 UTC