php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30420 mysql_connect is out of function due to Change of key-length in mysql 4.1.x
Submitted: 2004-10-13 09:38 UTC Modified: 2004-10-13 09:46 UTC
From: slartibartfass at web dot de Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.9 OS: any
Private report: No CVE-ID: None
 [2004-10-13 09:38 UTC] slartibartfass at web dot de
Description:
------------
on http://dev.mysql.com/doc/mysql/en/News-4.1.1.html the following is stated:

- Warning: Incompatible change! Client authentication now is
- based on 41-byte passwords in the user table, not 45-byte
- passwords as in 4.1.0. Any 45-byte passwords created for 
- 4.1.0 must be reset after running the 
- mysql_fix_privilege_tables script.

----------------------------------------------------------
due to this change I can not connect to any mysql-server beyond 4.1.x via PHP/mysql_connect, cause mysql_connect seems to produce 45-Byte-password still....

...I would appreciate a quick workaround...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-13 09:46 UTC] georg@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

update your client libraries to 4.1 
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 04:03:45 2023 UTC