php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30403 configure can't get past libxml check
Submitted: 2004-10-11 20:19 UTC Modified: 2004-10-13 15:20 UTC
From: johnie dot stafford at citigroup dot com Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5.0.2 OS: Solaris 8
Private report: No CVE-ID: None
 [2004-10-11 20:19 UTC] johnie dot stafford at citigroup dot com
Description:
------------
I'm trying to run configure on Solaris 8. I've built and installed libxml2 version 2.6.14. Here is my configure commandline:

./configure --prefix=/opt/app/pkg/php-5.0.2 --with-apxs=/opt/app/apache/bin/apxs --with-exec-dir=/opt/app/pkg/php-5.0.2/bin --with-libxml-dir=/opt/app --with-openssl=/opt/app/pkg/openssl-0.9.7d --with-zlib --with-gd=/opt/app/pkg/gd-1.8.4 --with-mysql

checking whether libxml build works... no
configure: error: build test failed.  Please check the config.log for details.




Expected result:
----------------
Complete configure process

Actual result:
--------------
testing of libxml failed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-12 08:30 UTC] derick@php.net
The messages says:
configure: error: build test failed.  Please check the config.log for details.

Do that and tell us what's in there (last few lines most likely, search for libxml).
 [2004-10-13 15:20 UTC] johnie dot stafford at citigroup dot com
The problem was the gcc 2.* problem. The test code was missing the "__register_frame_info" reference. With a great deal of hacking of the configure script and the resulting Makefile, I was able to get php built.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 03:03:50 2022 UTC