php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30361 php4-cli cannot run in background
Submitted: 2004-10-08 12:02 UTC Modified: 2004-12-21 15:58 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: wim dot heirman at elis dot ugent dot be Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 4.3.10 OS: Debian Unstable
Private report: No CVE-ID: None
 [2004-10-08 12:02 UTC] wim dot heirman at elis dot ugent dot be
Description:
------------
When starting a PHP script from the commandline as a background process, the php process goes into stopped state immediatly.

Reproduce code:
---------------
bash> php foo.php &


Expected result:
----------------
PHP should execute foo.php in the background

Actual result:
--------------
The PHP process is suspended (state=T in a ps -ax). Bringing it to foreground with fg resumes the process, bg or kill -CONT however is not working.
This did work fine in PHP 4.3.8.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-12 01:54 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Works fine for me using latest CVS snapshot.

 [2004-12-14 10:52 UTC] wim dot heirman at elis dot ugent dot be
Works for me too, thanks!
 [2004-12-21 15:58 UTC] wim dot heirman at elis dot ugent dot be
With Debian's new package the problem is back, after playing around with the configure parameters I found that --with-readline works OK, but --with-libedit (which is used by Debian, but which I did not enable when testing the CVS snapshot) does not work (i.e. suspends the process when put in the background, even when no input is required). As it turns out, Debain started using libedit as of 4.3.9 (the first version in which this problem appeared), before that they used neither libedit nor libreadline.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Aug 04 07:01:24 2021 UTC