php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30181 domxml functions missing
Submitted: 2004-09-21 16:47 UTC Modified: 2004-09-21 18:45 UTC
From: abramov at fromru dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.0.1 OS: Linux
Private report: No CVE-ID: None
 [2004-09-21 16:47 UTC] abramov at fromru dot com
Description:
------------
I tried to compile php 5.0.1 with domxml support. Compilation was successful, but domxml - functions are missing! The only dom function is dom_import_simplexml:

[php-5.0.1]# sapi/cli/php |egrep -i '(xml|dom)'
<?
phpinfo();
print_r(get_defined_functions());
?>

Configure Command =>  './configure' '--with-dom=/usr/local' '--with-dom-xslt'
xmlrpc_error_number => 0 => 0
xmlrpc_errors => Off => Off
dom
DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.6.11
libxml
libXML support => active
libXML Version => 2.6.11
libXML streams => enabled
session.cookie_domain => no value => no value
SimpleXML
Simplexml support => enabled
Classes => ArrayObject, ArrayIterator, CachingIterator, CachingRecursiveIterator, DirectoryIterator, FilterIterator, LimitIterator, ParentIterator, RecursiveDirectoryIterator, RecursiveIteratorIterator, SimpleXMLIterator
xml
XML Support => active
XML Namespace Support => active
libxml2 Version => 2.6.11
OLDPWD => /usr/src/libxml2-2.6.11
_SERVER["OLDPWD"] => /usr/src/libxml2-2.6.11
_ENV["OLDPWD"] => /usr/src/libxml2-2.6.11
            [43] => xml_parser_create
            [44] => xml_parser_create_ns
            [45] => xml_set_object
            [46] => xml_set_element_handler
            [47] => xml_set_character_data_handler
            [48] => xml_set_processing_instruction_handler
            [49] => xml_set_default_handler
            [50] => xml_set_unparsed_entity_decl_handler
            [51] => xml_set_notation_decl_handler
            [52] => xml_set_external_entity_ref_handler
            [53] => xml_set_start_namespace_decl_handler
            [54] => xml_set_end_namespace_decl_handler
            [55] => xml_parse
            [56] => xml_parse_into_struct
            [57] => xml_get_error_code
            [58] => xml_error_string
            [59] => xml_get_current_line_number
            [60] => xml_get_current_column_number
            [61] => xml_get_current_byte_index
            [62] => xml_parser_free
            [63] => xml_parser_set_option
            [64] => xml_parser_get_option
            [611] => simplexml_load_file
            [612] => simplexml_load_string
            [613] => simplexml_import_dom
            [685] => dom_import_simplexml
            [697] => libxml_set_streams_context




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-21 18:45 UTC] chregu@php.net
Not a bug. 
Please check ./configure --help
the domxml extension isn't anymore, it's "dom" now

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 03:01:32 2024 UTC