|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30160 Installing PHP SAPI module fails
Submitted: 2004-09-20 08:36 UTC Modified: 2005-04-06 18:36 UTC
Avg. Score:4.5 ± 0.8
Reproduced:11 of 11 (100.0%)
Same Version:3 (27.3%)
Same OS:4 (36.4%)
From: tessarek at evermeet dot cx Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5CVS-2005-03-24 OS: AIX 5.x
Private report: No CVE-ID: None
 [2004-09-20 08:36 UTC] tessarek at evermeet dot cx
This problem came with PHP 5.0.0 and is still there in 5.0.1.

The make of PHP 5.0.x works fine, but when running the 'make install', I get following error:

Installing PHP SAPI module:       apache2filter
/opt/apache/build/ SH_LIBTOOL='/opt/apache/build/libtool' /opt/apache/modules
rm -f /opt/apache/modules/
/opt/apache/build/libtool --mode=install cp /opt/apache/modules/
cp .libs/libphp5.a /opt/apache/modules/libphp5.a
cp .libs/libphp5.lai /opt/apache/modules/
libtool: install: warning: remember to run `libtool --finish /ext/php-5.0.1/libs'
chmod 755 /opt/apache/modules/
chmod: /opt/apache/modules/ A file or directory in the path name does not exist.
apxs:Error: Command failed with rc=65536
make: 1254-004 The error code from the last command is 1.

There seems something wrong with the makefile.
With PHP 4.x.x I never had this problem.

My Apache version is 2.0.51, but the problem is also reproducable with older versions.

It is kind of funny, because there is a file in the /ext/php-5.0.1/.libs directory, where /ext/php-5.0.1/ is my compilation directory.
I can copy the file manually to my Apache modules directory and everything works fine.
The only problem is that when I do it manually, there is nothing in my PHP target (/opt/php) directory.

My configure line is as follows:

./configure --prefix=/opt/php --with-config-file-path=/etc --with-apxs2filter=/opt/apache/bin/apxs --without-mysql --with-ibm-db2=/usr/opt/db2_08_01 --with-xml --enable-cli --disable-ipv6 --enable-force-cgi-redirect --disable-debug --enable-pic --enable-inline-optimization --with-ncurses --with-iconv --with-regex=system --enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-wddx --without-oci8 --enable-ucd-snmp-hack --enable-memory-limit --enable-shmop --enable-versioning --enable-calendar --enable-dbx --enable-dio --enable-mcal --with-gettext --with-dom --with-zlib --with-zlib-dir=/usr/lib --with-imap --with-openssl=/opt/freeware --with-gd --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-pdflib --without-sqlite --with-bz2

The problem occurs under AIX 5.1 / AIX 5.2 / Redhat 8.0 / Redhat 9.0 and Redhat Enterprise Server 3.0.
(These are the systems I've tested it on.)

I hope that this bug has not already been submitted, because I haven't found anything in the bug database.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-24 18:48 UTC]
I removed most comments, none of them gave any additional information that you haven't already given in your initial comment. Please don't add only NEW information from now on.
And try to post only answers to what we ask, NOTHING else.

 [2005-03-24 18:48 UTC]
What do these commands output:

# grep --version
# egrep --version
# sed --version
 [2005-04-01 14:44 UTC] tessarek at evermeet dot cx
vulcan14:[root] /> grep --version
grep: Not a recognized flag: -
Usage: grep [-r] [-R] [-H] [-L] [-E|-F] [-c|-l|-q] [-insvxbhwy] [-p[parasep]] -e pattern_list...
        [-f pattern_file...] [file...]
Usage: grep [-r] [-R] [-H] [-L]  [-E|-F] [-c|-l|-q] [-insvxbhwy] [-p[parasep]] [-e pattern_list...]
        -f pattern_file... [file...]
Usage: grep [-r] [-R] [-H] [-L] [-E|-F] [-c|-l|-q] [-insvxbhwy] [-p[parasep]] pattern_list [file...]

vulcan14:[root] /> egrep --version
egrep: Not a recognized flag: -
Usage: egrep [-r] [-R] [-H] [-L] [-hisvwxy] [[-bn]|[-c|-l|-q]] [-p[parasep]] -e pattern_list...
        [-f pattern_file...] [file...]
Usage: egrep [-r] [-R] [-H] [-L] [-hisvwxy] [[-bn]|[-c|-l|-q]] [-p[parasep]] [-e pattern_list...]
        -f pattern_file... [file...]
Usage: egrep [-r] [-R] [-H] [-L] [-hisvwxy] [[-bn]|[-c|-l|-q]] [-p[parasep]] pattern_list [file...]

vulcan14:[root] /> sed --version
sed: Not a recognized flag: -
Usage:  sed [-n] Script [File ...]
        sed [-n] [-e Script] ... [-f Script_file] ... [File ...]
 [2005-04-04 21:15 UTC]
For the install to work you need GNU tools (grep,sed,etc..)

 [2005-04-06 18:36 UTC] tessarek at evermeet dot cx
I've installed the GNU tools (see versions below).
Unfortunately I still get the same error message. 

vulcan14:[root] /> grep --version
grep (GNU grep) 2.5.1

vulcan14:[root] /> egrep --version
egrep (GNU grep) 2.5.1

vulcan14:[root] /> sed --version
GNU sed version 4.0.7
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Dec 02 10:01:26 2023 UTC