php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30115 The wrong link is shown for __destruct() when using phpmanual
Submitted: 2004-09-16 15:15 UTC Modified: 2004-09-21 23:55 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: richard dot quadling at bandvulc dot co dot uk Assigned:
Status: Wont fix Package: Unknown/Other Function
PHP Version: all OS: n/a
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-09-16 15:15 UTC] richard dot quadling at bandvulc dot co dot uk
Description:
------------
I use the phpmanual facility so that I can get links to the function that fails, when it fails.

My code failed showing ...

Warning: FormMaint::__destruct() [function.--destruct.html]: message: Cannot insert duplicate key row in object 'kpi_element_types' with unique index 'IX_element_types_ElementTypeExecutionSequence'. (severity 14) in C:\WebSites\PHP\Includes\class_FormMaint.inc on line 239

The important bit is [function.--destruct.html] which points to url ...

http://dev.kpi.bandvulc/phpmanual/function.--destruct.html

which doesn't exist.


Reproduce code:
---------------
Generating the error was VERY hard work (i.e. 1 line in the wrong place), but is not relevant to the problem. The problem is that there is no documentation for function.--desctruct.html




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-18 12:51 UTC] nlopess@php.net
The __destruct() method is documented.
 [2004-09-20 09:10 UTC] richard dot quadling at bandvulc dot co dot uk
What criteria is used to ID a bug report as bogus?

I said "Documentation problem".

You say it IS documented, but not with regards to the phpmanual facility activated within PHP.INI?

I'm using the latest HTML manuals available (28-8-2004).

There is no page called function.--destuct.html in the archive available from www.php.net.

I do not see how this is bogus?

Richard Quadling.
 [2004-09-20 18:50 UTC] nlopess@php.net
The problem is that we don't have a function ID for the __destruct() method (and won't have this).
PHP will generate valid links for almost every function, but it won't work for OOP methods, as they are documented in a different place (language reference chapter).

As PHP can't imagine where every single function is documented, this won't be fixed (any other php member speak if is against!).
 [2004-09-20 22:32 UTC] goba@php.net
Special methods need special handling. I guess PHP developers would not like the docs to have the __destruct() function(!) documented with a dumb page, so the error reporting code should be able to detect if it is about a special OO function, and should direct to the right doc page IMHO.
 [2004-09-21 23:55 UTC] derick@php.net
Perhaps the PHP developers can also fix the code for the people? If "destruct" is generated as link, then the doc system should handle it.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 03:01:27 2019 UTC