php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30005 image header problem
Submitted: 2004-09-07 09:00 UTC Modified: 2004-09-07 09:23 UTC
From: r dot h dot zeelenberg at bravo-informatisering dot nl Assigned:
Status: Not a bug Package: *Graphics related
PHP Version: 4.3.9RC2 OS: redhat
Private report: No CVE-ID: None
 [2004-09-07 09:00 UTC] r dot h dot zeelenberg at bravo-informatisering dot nl
Description:
------------
Hi fellow-phpers..

I am having a strange problem...

I stripped my code to the basic to elimenate things..

What i've got...

php file get_test.php

This should place an image on the screen in verboden.php there should be some checks but i've wiped them out for clearification. So verboden.php is :

<?php
$documentroot=$_SERVER['DOCUMENT_ROOT'];
?>

get_test.php is :

<?php
$documentroot=$_SERVER['DOCUMENT_ROOT'];

#include($documentroot.'/verboden.php');

$afbeelding_file=$documentroot.'/images/geen_afbeelding_1.jpg';

header("Content-type: image/jpg");
$current_file=ImageCreateFromJPEG($afbeelding_file);
ImageJPEG ($current_file);
ImageDestroy($current_file);
?>

Attention! This works only!!! when i comment out the include for verboden.php
I think this is very strange... Firefox is saying there is something wrong with the image.. IE6 will try to download it.

Anyone idea's??

TIA

Ronald

ps this one ruined my sunday ;(


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-07 09:23 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 11:01:25 2019 UTC