php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29979 mysqli - compilation error
Submitted: 2004-09-04 17:43 UTC Modified: 2004-09-05 13:33 UTC
From: x-penguin at tut dot by Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5CVS-2004-09-04 (dev) OS: Linux
Private report: No CVE-ID: None
 [2004-09-04 17:43 UTC] x-penguin at tut dot by
Description:
------------
./configure --prefix=/usr/ --with-apxs2 --with-gettext --with-iconv --with-mysql=/usr --with-mysql-sock=/tmp/mysql.sock --enable-mbstring=ru --enable-mbregex --enable-mbstr-enc-trans --disable-short-tags --with-xsl --with-libxml --without-sqlite --enable-soap --with-pgsql --with-mysqli=/opt/mysql-4.1.3/bin/mysql_config --with-mysqli-sock=/tmp/mysql-4.1.3.sock


/bin/sh /mnt/data/Sources/php-src/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/mysqli/ -I/mnt/data/Sources/php-src/ext/mysqli/ -DPHP_ATOM_INC -I/mnt/data/Sources/php-src/include -I/mnt/data/Sources/php-src/main -I/mnt/data/Sources/php-src -I/mnt/data/Sources/php-src/Zend -I/usr//include/libxml2 -I/mnt/data/Sources/php-src/ext/mbstring/oniguruma -I/mnt/data/Sources/php-src/ext/mbstring/libmbfl -I/mnt/data/Sources/php-src/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/opt/mysql-4.1.3/include/mysql -I/usr//include  -I/mnt/data/Sources/php-src/TSRM  -g -O2  -prefer-pic -c /mnt/data/Sources/php-src/ext/mysqli/mysqli.c -o ext/mysqli/mysqli.lo
In file included from /mnt/data/Sources/php-src/ext/mysqli/mysqli.c:31:
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:48: error: syntax error before "MYSQL_STMT"
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:48: warning: no semicolon at end of struct or union
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:52: error: syntax error before '}' token
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:52: warning: data definition has no type or storage class
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:85: error: `LOCAL_INFILE_ERROR_LEN' undeclared here (not in a function)
/mnt/data/Sources/php-src/ext/mysqli/php_mysqli.h:113: error: syntax error before '*' token
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:91: error: syntax error before '*' token
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c: In function `php_clear_stmt_bind':
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:93: error: `stmt' undeclared (first use in this function)
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:93: error: (Each undeclared identifier is reported only once
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:93: error: for each function it appears in.)
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c: In function `mysqli_objects_free_storage':
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:140: error: syntax error before ')' token
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c: In function `mysqli_read_property':
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:210: error: `MYSQL_STMT' undeclared (first use in this function)
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:210: error: syntax error before ')' token
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:210: error: syntax error before ')' token
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c: In function `zm_startup_mysqli':
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:459: error: `STMT_ATTR_UPDATE_MAX_LENGTH' undeclared (first use in this function)
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:517: error: `MYSQL_NO_DATA' undeclared (first use in this function)
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c: In function `php_mysqli_fetch_into_hash':
/mnt/data/Sources/php-src/ext/mysqli/mysqli.c:626: error: syntax error before ')' token
make: *** [ext/mysqli/mysqli.lo] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-04 19:20 UTC] georg@php.net
RTFM! 
 
From our fine manual: 
 
Installation 
 
 To install the mysqli extension for PHP, use the 
--with-mysqli=mysql_config_path/mysql_config configuration 
option where mysql_config_path represents the location of 
the mysql_config program that comes with MySQL versions 
greater than 4.1.  
 
If you would like to install the mysql extension along 
with the mysqli extension you have to use the same client 
library to avoid any conflicts.  
 [2004-09-04 20:06 UTC] x-penguin at tut dot by
:) yes, I read this manual, and I use client libraries from mysql4.1...
 [2004-09-04 21:52 UTC] schlueter at phpbar dot de
As Georg wrote: Both - MySQL and MySQLi need the same  
library and you are using one in /usr and one in /opt
 [2004-09-04 22:16 UTC] x-penguin at tut dot by
client libraries are located only in /usr/lib:
/usr/lib/libmysqlclient_r.so         /usr/lib/libmysqlclient.so
/usr/lib/libmysqlclient_r.so.14      /usr/lib/libmysqlclient.so.14
/usr/lib/libmysqlclient_r.so.14.0.0  /usr/lib/libmysqlclient.so.14.0.0
 [2004-09-05 13:04 UTC] nospam at nospam dot org
Guys, why don't ask your sys admins to install the things 
for you instead to bother php dev's with your broken 
systems? 
 
The errormessage indicates, that an include file is used, 
which is from versions < 4.1. Fix your broken installation 
first!
 [2004-09-05 13:33 UTC] tony2001@php.net
x-penguin at tut dot by:
Georg pointed you out the problem. Fix your mysql install and figure out why there are old headers in your system.

Not a PHP bug -> bogus.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 09 20:01:23 2021 UTC