php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29928 glob() returns false instead of an ampty array, again
Submitted: 2004-09-01 10:05 UTC Modified: 2004-12-13 01:27 UTC
From: rossen dot radonov at ecad dot tu-sofia dot bg Assigned:
Status: Closed Package: *Directory/Filesystem functions
PHP Version: 4.3.9RC2 OS: Solaris 8
Private report: No CVE-ID:
 [2004-09-01 10:05 UTC] rossen dot radonov at ecad dot tu-sofia dot bg
Description:
------------
glob() returns false instead of an empty array.
I was using version 4.3.7 and everything was OK. Then I upgraded to 4.3.9RC1 and 4.3.9RC2 and the problem appeared.
I looked in the bug-report database and saw simillar problems, then downloaded the php4-STABLE-200409010630 version, compiled it and the results were the same.
Is this a bug or a normal behavior?


Reproduce code:
---------------
$files = glob("/some_empty_dir/*");
var_dump($files);


Expected result:
----------------
array(0) {
} 

Actual result:
--------------
bool(false)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-01 10:26 UTC] derick@php.net
Duplicate of bug #28649 (which was closed). I reopened that one and marking this one as bogus (as it was already reported).
 [2004-12-13 01:27 UTC] sniper@php.net
Fixed.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 20:01:57 2014 UTC