php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29842 soapclient return null value
Submitted: 2004-08-25 20:55 UTC Modified: 2004-08-27 09:12 UTC
From: mobi at delfnet dot pL Assigned: dmitry
Status: Closed Package: SOAP related
PHP Version: 5CVS-2004-08-26 (dev) OS: Win2000 SP4
Private report: No CVE-ID:
 [2004-08-25 20:55 UTC] mobi at delfnet dot pL
Description:
------------
SOAP result is null (wsdl file is correct and WebService works).
The following pice of code explain the problem:

Reproduce code:
---------------
$wsdl = new SoapClient('http://wsrp.netunitysoftware.com/WSRPTestService/WSRPTestService.asmx?Operation=WSDL',array('trace' => 1));

$RegistrationData =
  array("consumerName" => "test",
        "consumerAgent" => "test.1.0",
        "methodGetSupported" => false,        
        "consumerModes" => array('wsrp:view','wsrp:edit'),  
        "consumerWindowStates" => array('wsrp:view','wsrp:edit'),
        "consumerUserScopes" => array(),
        "customUserProfileData" => array(),
        "registrationProperties" => array(),
        "extensions" => array());

print_r($wsdl->register($RegistrationData_Type));



Expected result:
----------------
SOAP RESULT:

<?xml version="1.0" encoding="utf-8"?><soap:Envelope
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<registerResponse xmlns="urn:oasis:names:tc:wsrp:v1:types">
 <registrationHandle>1f9c4223-ce73-4cdf-b24f-fdd15d2066ad</registrationHandle> 
 </registerResponse>
 </soap:Body>
</soap:Envelope>

print:
Array
(
    [registrationHandle] => 1f9c4223-ce73-4cdf-b24f-fdd15d2066ad
)

Actual result:
--------------
SOAP RESULT:
the same as bottom

print:
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-26 14:53 UTC] dmitry@php.net
I cannot reproduce the bug.
I got "Consumer Name Parameter Missing" exception.

I hope, this is the same bug as #29844 that is just fixed in CVS.

 [2004-08-26 14:58 UTC] derick@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

Please try a snapshot dated AFTER Aug 26, 2004 13:00 GMT from snaps.php.net then.
 [2004-08-26 23:49 UTC] mobi at delfnet dot pL
In my code above should be:

print_r($wsdl->register($RegistrationData));
//not $RegistrationData_Type

I have tried php5-win32-200408261830.zip snapshot and the return value is still null.
 [2004-08-27 09:12 UTC] dmitry@php.net
Fixed in CVS (HEAD & PHP_5_0)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 18:01:53 2014 UTC