php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29835 OCI8 module could not load in IIS
Submitted: 2004-08-25 15:35 UTC Modified: 2004-08-25 17:18 UTC
From: izhekov at ppartner dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 5.0.1 OS: Windows 2003
Private report: No CVE-ID:
 [2004-08-25 15:35 UTC] izhekov at ppartner dot com
Description:
------------
I've tried to install PHP on IIS 6 with Oracle module support.
Everything is set correctly - the PHP installation instructions are executed, an Oracle client is installed, Oracle environments are set.

The problem is that when I try to open any .php script, the web server return an error message:
"Unable to load dynamic library c:\php\ext\php_oci8.dll: Access denied"

The file php_oci8.dll is right there and it have property permissions set. oci.dll is located in %ORACLE_HOME%\bin\. I've tried this on three different servers and the problem is on all of them. Oracle version is 9.2.0.1.0. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-25 17:18 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2004-08-28 10:47 UTC] christian at wenz dot org
php_oci8.dll does not only try to load oci.dll, but several other dlls from this directory, as well, so IUSR_MACHINENAME needs read access to the _complete_ bin directory (be sure to check the "replace permissions" options when setrting this).
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 02:02:11 2014 UTC