php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29783 IMAP module problem
Submitted: 2004-08-21 15:04 UTC Modified: 2004-08-21 20:25 UTC
From: bolk at hitv dot ru Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.9RC1 OS: RedHat 9 (2.4.20-8smp)
Private report: No CVE-ID:
 [2004-08-21 15:04 UTC] bolk at hitv dot ru
Description:
------------
Can't compile PHP with IMAP c-client module.

C-client version: imap-2004a.tar.Z (2004.7.15, 2`224`181)
PHP: 4.3.9RC1 and 4.3.8

Reproduce code:
---------------
./configure --with-imap=../imap-2004a

Actual result:
--------------
checking for pam_start in -lpam... yes
checking for crypt in -lcrypt... (cached) yes
checking whether SSL libraries are needed for c-client... no
checking whether IMAP works... no
configure: error: build test failed. Please check the config.log for details.

tail -30 config.log

/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9b9): In function `ssl_genkey':
/usr/src/imap-2004a/c-client/osdep.c:842: undefined reference to `RSA_generate_key'
/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9e7):/usr/src/imap-2004a/c-client/osdep.c:843: undefined reference to `ERR_get_error'
/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9f6):/usr/src/imap-2004a/c-client/osdep.c:846: undefined reference to `ERR_error_string'
collect2: ld returned 1 exit status
configure: failed program was:
#line 41357 "configure"
#include "confdefs.h"

    void mm_log(void){}
    void mm_dlog(void){}
    void mm_flags(void){}
    void mm_fatal(void){}
    void mm_critical(void){}
    void mm_nocritical(void){}
    void mm_notify(void){}
    void mm_login(void){}
    void mm_diskerror(void){}
    void mm_status(void){}
    void mm_lsub(void){}
    void mm_list(void){}
    void mm_exists(void){}
    void mm_searched(void){}
    void mm_expunged(void){}
    char mail_newbody();
    int main() {
      mail_newbody();
      return 0;
    }


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-21 16:24 UTC] derick@php.net
This is a problem with the redhat binaries, just add --with-openssl to your build and it should work fine.
 [2004-08-21 16:29 UTC] bolk at hitv dot ru
Yeah, it's works with '--with-imap-ssl'. Thank you :)
 [2004-08-21 16:34 UTC] bolk at hitv dot ru
Hmm... But I have no IMAP support in my PHP:

checking for IMAP support... no


[root@domain php-4.3.9RC1]# php -m|grep -i imap|wc -l
      0
[root@domain php-4.3.9RC1]#
 [2004-08-21 16:36 UTC] bolk at hitv dot ru
./configure --with-imap=../imap-2004a --with-ssl

checking whether SSL libraries are needed for c-client... no
checking whether IMAP works... no
configure: error: build test failed. Please check the config.log for details.

[root@domain php-4.3.9RC1]# tail -30 config.log 
/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9b9): In function `ssl_genkey':
/usr/src/imap-2004a/c-client/osdep.c:842: undefined reference to `RSA_generate_key'
/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9e7):/usr/src/imap-2004a/c-client/osdep.c:843: undefined reference to `ERR_get_error'
/usr/src/imap-2004a/c-client/libc-client.a(osdep.o)(.text+0xb9f6):/usr/src/imap-2004a/c-client/osdep.c:846: undefined reference to `ERR_error_string'
collect2: ld returned 1 exit status
configure: failed program was:
#line 41357 "configure"
#include "confdefs.h"

    void mm_log(void){}
    void mm_dlog(void){}
    void mm_flags(void){}
    void mm_fatal(void){}
    void mm_critical(void){}
    void mm_nocritical(void){}
    void mm_notify(void){}
    void mm_login(void){}
    void mm_diskerror(void){}
    void mm_status(void){}
    void mm_lsub(void){}
    void mm_list(void){}
    void mm_exists(void){}
    void mm_searched(void){}
    void mm_expunged(void){}
    char mail_newbody();
    int main() {
      mail_newbody();
      return 0;
    }
 [2004-08-21 16:42 UTC] bolk at hitv dot ru
Oops.. I'm stupid inattentive bastard. Sorry :)

With **openssl** it was compiled successfully.
 [2004-08-21 16:42 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

I said --with-openssl, you use --with-ssl which does not exist. Please , ask for support questions on the php-general@lists.php.net mailinglist. You're doing something wrong.
 [2004-08-21 16:46 UTC] bolk at hitv dot ru
Thank for your help!
 [2004-08-21 20:25 UTC] tony2001@php.net
Not a bug -> bogus.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 13:02:46 2014 UTC