php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29701 installers missing from php mirror sites
Submitted: 2004-08-16 11:20 UTC Modified: 2004-08-19 16:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: goba@php.net Assigned:
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
 [2004-08-16 11:20 UTC] goba@php.net
Description:
------------
Several users and mirror admins reported, that the Windows installers are missing from the mirrors sites. Shimi (a mirror admin) reports that all .exe files are missing from the rsynced site:

  http://news.php.net/php.mirrors/25815

Reproduce code:
---------------
http://www.php.net/get/php-4.3.8-installer.exe/from/a/mirror
http://www.php.net/get/php-5.0.0-installer.exe/from/a/mirror


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-16 13:52 UTC] edink@php.net
All of those files are on rsync server. Do they get any error messages while rsyncing?
 [2004-08-16 18:24 UTC] shimi at shimi dot net
I ran the following command manually:

$ /usr/bin/rsync -avzC --delete --delete-after \
--exclude='stats/**' rsync.php.net::phpweb \
/var/mirrors/il.php.net/www/

I got:

receiving file list ...
done

Followed by a tree of the phpweb directory listing.

A few files were updated (rsync works...) (so it looks) :
backend/notes/all.bz2
backend/notes/last-updated
backend/notes/sections
include/countries.inc
include/last_updated.inc
include/mirrors.inc
include/pregen-events.inc
mirrorkit.tgz

And then:
wrote 22529 bytes  read 2576333 bytes  6921.07 bytes/sec
total size is 1133334821  speedup is 436.09

I must note, however, that the sync is *really* slow (comparing to, gentoo tree syncs, for instance...)

No errors I could notice. Partition that holds the mirror has 15GB free space.
 [2004-08-16 18:27 UTC] goba@php.net
This issue can be reporoduced on other mirrors too, so it is not only an issue on shimi's mirror.
 [2004-08-19 07:45 UTC] goba@php.net
Could someone please look into this? We receive an increasing amount of reports about this issue!
 [2004-08-19 16:21 UTC] derick@php.net
It's a problem with our installation instructions which say to use -C as an option to rsync. For newer clients this excludes .exe files for the rsync space. Simply adding --include='distributions/*.exe' fixes it (or removing -C).
 [2004-08-19 16:50 UTC] shimi at shimi dot net
Derick, I did not update the rsync client lately. What caused the change? If I use the same rsync client, why would the behavior change? It's not that my mirror is running on Windows or something... things don't just change like that, right? Perhaps someone changed something at the rsync server, and that is the cause for the problem?
 [2004-08-19 16:55 UTC] shimi at shimi dot net
More about my previous comment:

I just did man rsync on my local home machine (running a quite up-to-date gentoo), and indeed *.exe is listed as excluded.

HOWEVER, looking on man rsync on the server that hosts the mirror, here is what the man says there:

       -C, --cvs-exclude
              This  is  a useful shorthand for excluding a broad range of files that you often don?t want to
              transfer between systems. It uses the same algorithm that CVS uses  to  determine  if  a  file
              should be ignored.

              The exclude list is initialized to:

              RCS/  SCCS/ CVS/ .svn/ CVS.adm RCSLOG cvslog.* tags TAGS .make.state .nse_depinfo *~ #* .#* ,*
              *.old *.bak *.BAK *.orig *.rej .del-* *.a *.o *.obj *.so *.Z *.elc *.ln core

              then files listed in a $HOME/.cvsignore are added to the list and  any  files  listed  in  the
              CVSIGNORE environment variable (space delimited).

              Finally,  any  file is ignored if it is in the same directory as a .cvsignore file and matches
              one of the patterns listed therein.  See the cvs(1) manual for more information.
 [2004-08-19 16:57 UTC] derick@php.net
The rsync "server" was updated due to a security leak and this new version now excludes *.exe too. Can't help that.
 [2004-08-19 17:06 UTC] shimi at shimi dot net
Oh, I understood from your wording that the clients are responsible for that (excluding files) - not the server.

I added --include='distributions/*.exe' to my cron job.

It seems to be working.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jan 21 22:01:23 2021 UTC