php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29665 PHP Fails to compile when soap is enabled
Submitted: 2004-08-14 00:19 UTC Modified: 2005-01-27 01:00 UTC
Votes:20
Avg. Score:4.2 ± 1.1
Reproduced:20 of 20 (100.0%)
Same Version:14 (70.0%)
Same OS:11 (55.0%)
From: moontumbo at hotmail dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.0.1 OS: Red Hat Enterprise Linux WS 3.0
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-08-14 00:19 UTC] moontumbo at hotmail dot com
Description:
------------
When PHP 5.0.1 is configured with SOAP support, the compilation fails.  We are using the same configure command that we used on PHP 5.0.0.  When soap is removed from the configure, it compiles cleanly.


Reproduce code:
---------------
'./configure' \
'--with-config-file-path=/usr/local/apache/conf' \
'--with-apxs=/usr/local/apache/bin/apxs' \
'--enable-sigchild' \
'--with-gd' \
'--enable-gd-native-ttf' \
'--with-freetype-dir=/usr/local/lib' \
'--with-jpeg-dir=/usr/lib' \
'--with-png-dir=/usr/local/lib' \
'--with-zlib-dir=/usr/local/lib' \
'--with-xpm-dir=/usr/lib' \
'--with-openssl' \
'--with-mysql' \
'--enable-soap' \
'--with-ldap' \
'--with-t1lib' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-ftp' \
"$@"
//Configures fine.  Make fails.
make



Expected result:
----------------
Successful compilation and installation upon make install.

Actual result:
--------------
ext/soap/php_encoding.lo(.text+0x5b7): In function `to_zval_string':
/usr/local/src/php/php-5.0.1/ext/soap/php_encoding.c:467: undefined reference to 
`xmlBufferCreateStatic'
ext/soap/php_encoding.lo(.text+0x8d5): In function `to_zval_stringr':
/usr/local/src/php/php-5.0.1/ext/soap/php_encoding.c:503: undefined reference to 
`xmlBufferCreateStatic'
ext/soap/php_encoding.lo(.text+0xbf3): In function `to_zval_stringc':
/usr/local/src/php/php-5.0.1/ext/soap/php_encoding.c:539: undefined reference to 
`xmlBufferCreateStatic'
ext/soap/php_encoding.lo(.text+0x1125): In function `to_xml_string':
/usr/local/src/php/php-5.0.1/ext/soap/php_encoding.c:607: undefined reference to 
`xmlBufferCreateStatic'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-16 21:51 UTC] ppritzl at hotmail dot com
Upgrading the libxml2 to 2.6.11-1 solved this issue for me on both RH9 and RH Enterprise
 [2004-08-17 08:06 UTC] derick@php.net
Which libxml2 did you have installed before?
 [2004-08-17 23:17 UTC] ibrash at gaernin dot aswwc dot net
Issue reproduced on Slackware 9.1 with libxml2 2.5.11.
 [2004-08-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2004-08-28 16:52 UTC] michiel at dotgeek dot org
same problem, slack 9.0 
 
$ xml2-config --version 
2.6.12
 [2004-08-31 01:30 UTC] clewis at myfonts dot com
I too saw this problem on RedHat Enterprise 3 using 
libxml2 2.5.10.  Upgrading to 2.6.12 solved the problem.
 [2004-09-03 13:56 UTC] amit dot gupta at prudence-india dot com
Yes upgrading to libxml2-2.6* solves this problem
 [2004-09-07 11:15 UTC] luis at infomed dot sld dot cu
Upgrade to 2.6.8 or similar, BUT NOT TO 2.6.13 cause have a bug.
 [2004-10-09 06:49 UTC] yansanmo at iquebec dot com
On Redhat9, work well when I updated libxml2 packages to 
2.6.14 (-devel and -python too). 
I downloaded the 3 packages on this site: 
http://xmlsoft.org/sources/
 [2004-11-16 15:44 UTC] ykobayas at zet dot co dot jp
Same problem happened on PHP 5.0.2.
On RedHat Enterprise Linux ES 3.0, upgrading the libxml2 packages to 2.6.16 solved this problem too.
 [2005-01-19 01:41 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-01-27 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-09-23 19:35 UTC] mohsen dot gamshad at schwab dot com
I upgraded to libxml2 2.6.22 and I still get compile errors with enable-soap option:

ext/soap/php_encoding.lo(.text+0x5a4): In function `to_zval_string':
/php/ext/soap/php_encoding.c:505: undefined reference to `xmlBufferCreateStatic'

ext/soap/php_encoding.lo(.text+0x77e): In function `to_zval_stringr':
/php/ext/soap/php_encoding.c:541: undefined reference to `xmlBufferCreateStatic'

ext/soap/php_encoding.lo(.text+0x95a): In function `to_zval_stringc':
/php/ext/soap/php_encoding.c:577: undefined reference to `xmlBufferCreateStatic'

ext/soap/php_encoding.lo(.text+0xc28): In function `to_xml_string':
/php/ext/soap/php_encoding.c:645: undefined reference to `xmlBufferCreateStatic'
 [2005-11-08 23:26 UTC] admin at isprohosting dot com
Red Hat Enterprise Linux ES release 3 (Taroon Update 6)

Having the latest libxml2 provided by RedHat - libxml2-2.5.10-7

Compiling the PHP 5.0.4 and it fails.

There is no updated package from RedHat and I guess issue should be taken care by PHP team?
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC