php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29624 OCINlsEnvironmentVariableGet: referenced symbol not found
Submitted: 2004-08-12 03:01 UTC Modified: 2004-08-27 01:00 UTC
From: dmarek1 at att dot net Assigned:
Status: No Feedback Package: OCI8 related
PHP Version: 5.0.0 OS: Solaris 2.8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-08-12 03:01 UTC] dmarek1 at att dot net
Description:
------------
I am okay to build oci8 with PHP 5 and the make is okay but when I start http server the error below occurs.  I have iAS 10g for one home with a 9.2 client on another.  I build oci8 to 9.2 home and all other to 10G iAS.  Without oci8 all is good and the server runs and handles PHP but with oci8 I can't go on.

Thanks for any help

/opt/oracle/product/TCLB/iAS/Apache/Apache/bin/apachectl start: execing httpd
Syntax error on line 232 of /opt/oracle/product/TCLB/iAS/Apache/Apache/conf/httpd.conf:
Cannot load /opt/oracle/product/TCLB/iAS/Apache/Apache/libexec/libphp5.so into server: ld.so.1: /opt/oracle/product/TCLB/i
AS/Apache/Apache/bin/httpd: fatal: relocation error: file /opt/oracle/product/TCLB/iAS/Apache/Apache/libexec/libphp5.so: s
ymbol OCINlsEnvironmentVariableGet: referenced symbol not found

Reproduce code:
---------------
./configure --with-oci8=/opt/oracle/product/TCLB/9.2.C --with-gd=/usr/local --with-jpeg-dir=/usr/local --with-png-dir=/usr
/local --with-zlib-dir=/usr/local --with-xpm-dir=/usr/local --with-ttf=/usr/local --with-freetype-dir=/usr/local --enable-
gd-native-ttf --with-mysql=/usr/local/mysql --with-apxs=/opt/oracle/product/TCLB/iAS/Apache/Apache/bin/apxs --prefix=/opt/
oracle/product/TCLB/iAS --with-config-file-path=/opt/oracle/product/TCLB/iAS/Apache/Apache/conf


Expected result:
----------------
Server starts and oci calls work!

Actual result:
--------------
Can't start server as error above shows.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-13 02:17 UTC] cjbj at hotmail dot com
I guess at runtime you're using the Oracle DB libraries that came with iAS.  These are probably older than the DB
environment you built with.  Try building with the ORACLE_HOME
that you are running with.  See
http://www.oracle.com/technology/products/ias/ohs/htdocs/php_ohs.htm
 [2004-08-27 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 11:05:46 2022 UTC