|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29554 compile failure when using --with-pspell=/usr/local
Submitted: 2004-08-06 20:45 UTC Modified: 2005-02-17 04:52 UTC
Avg. Score:4.0 ± 1.0
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:1 (25.0%)
From: John at Albin dot Net Assigned:
Status: Closed Package: Pspell related
PHP Version: 4CVS, 5CVS (2005-02-03) OS: *
Private report: No CVE-ID: None
 [2004-08-06 20:45 UTC] John at Albin dot Net
 * Mac OS X 10.3.4
 * aspell 0.50.5 and aspell-en 0.51-1
   (installed into /usr/local from source files)
 * PHP 4.3.8

I've verified that aspell works from the command line, 
but PHP won't compile.

I'm configuring with '--with-pspell=/usr/local' and when 
I run make, it errors out saying: "ld: ext/pspell/
pspell.o illegal reference to symbol: 
_aspell_error_number defined in indirectly referenced 
dynamic library /usr/local/lib/libaspell.15.dylib"

I have never installed pspell. And I have installed 
aspell for the first time today on this machine. When I 
run 'sudo /usr/libexec/locate.updatedb' and then 'locate 
libpspell' I find (ignoring my build directory in /usr/
'locate libaspell' returns: 

The compile error is easily fixed with a small change to 
'configure'.  PHP compiles fine, when I edit php-4.3.8/
configure and change line 71624 from:
  LIBS="-lpspell $LIBS"
  LIBS="-laspell -lpspell $LIBS"

I have also talked to other Mac OS X/PHP/aspell users 
who have the same issue and the configure modification 
fixes their issue as well.

This bug is very similar to bug #23089. From looking at 
that bug, it seems that this bug might be reproducable 
on any machine that has no legacy aspell/pspell 
libraries and only the most recent aspell library.

Undoubtably, this was caused my the author of aspell 
changing the name of the library multiple times.  But 
can this relatively minor fix please be added to PHP's 
configure script?

Or would this impact Pspell users (those without the 
newer aspell)? If so, is there a way to check for this 
in the configure file? Unfortunately, I'm not an expert 
in configure files or I would attempt a patch myself.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-19 21:50 UTC] dhaveconfig at elitemail dot org
same issue with OS X Server 10.3.7 and php 4.3.10.

same fix resolved it.
 [2005-02-16 01:09 UTC] John at Albin dot Net
As per sniper's request, I tried the latest CVS 
snapshot, php4-STABLE-200502152130, but received the 
same error during compile:

ld: ext/pspell/pspell.o illegal reference to symbol: 
_aspell_word_list_elements defined in indirectly 
referenced dynamic library /usr/local/lib/

The fix mentioned in my first posting still works.
 [2005-02-17 04:51 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 02:01:30 2024 UTC