PHP :: Bug #29491 :: php crashes when dividing 0
php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29491 php crashes when dividing 0
Submitted: 2004-08-02 13:30 UTC Modified: 2004-08-02 13:38 UTC
From: florian dot wolfsjaeger at chello dot at Assigned:
Status: Closed Package: BC math related
PHP Version: 5.0.0 OS: WinXP SP1
Private report: No CVE-ID: None
 [2004-08-02 13:30 UTC] florian dot wolfsjaeger at chello dot at
Description:
------------
PHP 5.0.0 crashes when dividing 0 - using bcdiv() - by any number, but with all of the previous versions of PHP the function returned 0. I am using the PHP-5.0.0-zip-Package on Windows XP with Apache 2.0.50 ... PHP is installed as a module and resetting the php.ini to it's original didn't solve the problem.

Reproduce code:
---------------
bcdiv(0,4)

Expected result:
----------------
The function should just return the integer 0.

Actual result:
--------------
PHP crashes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-02 13:36 UTC] edink@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.
 [2004-08-02 13:37 UTC] tony2001@php.net
Pls, try to run the same code in console, using PHP-CLI (php.exe).
I can't reproduce it under Win2k & Linux.
 [2004-08-02 13:38 UTC] tony2001@php.net
Closed.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Aug 14 08:01:25 2018 UTC