php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29453 IMAP support breaks .so
Submitted: 2004-07-30 01:52 UTC Modified: 2010-12-20 10:25 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: datenpunk@php.net Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.0.0 OS: Gentoo Linux x86_64 (Opteron)
Private report: No CVE-ID: None
 [2004-07-30 01:52 UTC] datenpunk@php.net
Description:
------------
Hello,

I know that this has been an issue some times bevore and I really looked into each and every bugreport which mentions it.
I am not able to compile php-5.0.0 with imap support on my Gentoo boxes.

If I don't add imap support it works without problems.

It doesn't make a difference if I add ssl support or not.

So if you know emerge:

USE='ssl' emerge c-client /usr/portage/dev-php/mod_php/mod_php-5.0.0.ebuild

USE='-ssl' emerge c-client /usr/portage/dev-php/mod_php/mod_php-5.0.0.ebuild

Both fail.

I even tried different versions of libtool.

Maybe someone can help me out.

Thank you.


-- 
Daniel Khan


Reproduce code:
---------------
./configure  --prefix=/usr --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-apxs2=/usr/sbin/apxs2 --with-config-file-path=/etc/php/apache2-php5 --without-pear --disable-bcmath --with-bz2 --disable-calendar --without-cpdflib --disable-ctype --with-curl --without-curlwrappers --disable-dbase --disable-dio --enable-exif --without-fam --without-fbsql --without-fdftk --disable-filepro --enable-ftp --with-gettext --without-gmp --without-hwapi --without-iconv --without-informix --without-ingres --without-interbase --enable-mbstring --with-mcrypt --without-mcve --disable-memory-limit --without-mhash --without-mime-magic --with-ming --without-mnogosearch --without-msql --without-mssql --with-ncurses --without-oci8 --without-oracle --with-openssl --without-ovrimos --enable-pcntl --without-pfpro --without-pgsql --with-pspell --without-recode --disable-shmop --without-snmp --enable-soap --enable-sockets --disable-spl --without-sybase --without-sybase-ct --enable-sysvmsg --enable-sysvsem --enable-sysvshm --with-tidy --enable-wddx --with-xsl --without-xmlrpc --disable-yp --with-zlib --without-cdb --with-db4 --without-dbm --without-flatfile --with-gdbm --without-inifile --without-qdbm --enable-dbx --with-freetype-dir --with-t1lib --enable-gd-jis-conf --enable-gd-native-ttf --with-jpeg-dir=/usr --with-png-dir=/usr --with-tiff-dir=/usr --without-xpm-dir --with-gd --with-imap --with-imap-ssl --with-ldap --with-ldap-sasl --with-unixODBC --without-adabas --without-birdstep --without-dbmaker --without-empress --without-esoob --with-ibm-db2 --without-iodbc --without-sapdb --without-solid --with-mysql --without-mm --without-msession --enable-sqlite-utf8 --enable-dba --with-readline --without-libedit


Expected result:
----------------
A libphp5.so.

Actual result:
--------------
*** Warning: linker path does not have real file for library -lc-client.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libc-client and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib/c-client.a
/usr/lib/libc-client.a(osdep.o)(.text+0x8b69): In function `ssl_onceonlyinit':
: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.1/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libstdc++.so.5, needed by /home/db2inst1/sqllib/lib/libdb2.so, may conflict with libstdc++.so.6

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module libphp5.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).


>>> Install mod_php-5.0.0 into /var/tmp/portage/mod_php-5.0.0/image/ category dev-php
Installing PHP SAPI module:       apache2handler
/usr/lib/apache2/build/instdso.sh SH_LIBTOOL='/usr/lib/apache2/build/libtool' libphp5.la /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules
/usr/lib/apache2/build/libtool --mode=install cp libphp5.la /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/
cp .libs/libphp5.lai /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.la
cp .libs/libphp5.a /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.a
ranlib /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.a
chmod 644 /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.a
libtool: install: warning: remember to run `libtool --finish /var/tmp/portage/mod_php-5.0.0/work/php-5.0.0/libs'
Warning!  dlname not found in /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.so
chmod: cannot access `/var/tmp/portage/mod_php-5.0.0/image//usr/lib/apache2/modules/libphp5.so': No such file or directory
apxs:Error: Command failed with rc=65536
.
make: *** [install-sapi] Error 1

!!! ERROR: dev-php/mod_php-5.0.0 failed.
!!! Function php5-sapi_src_install, Line 394, Exitcode 2
!!! install failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-04 18:32 UTC] tony2001@php.net
What version of libtool do you use?
--
The following combinations are known to work:
autoconf 2.13, automake 1.4 and libtool 1.4.3
autoconf 2.13, automake 1.5 and libtool 1.4.3
--
(c) http://www.php.net/anoncvs.php

 [2004-09-12 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2004-09-13 20:05 UTC] datenpunk@php.net
libtool-1.5.2-r5
automake-1.8.5-r1
autoconf-2.59-r4

FYI:
I haven't had problems with other software yet and as it's a gentoo system nearly everything get's compiled from scratch.

My portage tree doesn't even offer autoconf-2.13 anymore btw.
I am on amd64 and so not that free in choosing older software versions.

Meanwhile I compiled the IMAP support as Dynamic Extension and it works now.

My config.nice for ext/imap looks like this:

CC='gcc' \
CXX='g++' \
'./configure' \
'--with-imap=/usr/lib/' \
'--with-imap-ssl' \
"$@"


BUT:
If I only do a ./configure I get:
checking whether SSL libraries are needed for c-client... no
checking whether build with IMAP works... no
configure: error: build test failed. Please check the config.log for details.

The config.log now show:
configure:4529: checking whether build with IMAP works
configure:4572: gcc -o conftest -g -O2   conftest.c  -lc-client -lcrypt -lpam   >&5
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.1/../../../libc-client.a(osdep.o)(.text+0x8b69): In function `ssl_onceonlyinit':
: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
----about 30 lines undefined references-----

So without knowing much about linking I can only guess what's happening here...

greetings

Daniel Khan
 [2004-09-14 08:36 UTC] derick@php.net
I'd say blame the Gentoo people for not offering solid programs. No bug here -> bogus.
 [2004-09-14 09:28 UTC] datenpunk@php.net
You may be right Derick. 
But it's a little weird that it works with php 4.x.
And it's also weird that I can compile a whole linux system with my build environment and only php5 reports problems.

Anyway - I was able to do a work around and if noone else thinks that this could be a php problem I agree with you to set this bug to bogus.
Thanks for looking into the issue Derick.

Daniel Khan
 [2004-09-17 17:30 UTC] mojoandy at yahoo dot com
I'm getting the same issue with Mandrake 10 on AMD64.  Exactly the same issue, so it ain't Gentoo.
 [2004-09-21 08:03 UTC] thierry dot salmon at just dot fgov dot be
Same problem with apache-1.3.31 + php-5.0.1 on RH9
-
apache
./configure --verbose \
            --prefix=/opt/WEB/apache-1.3.31_compiled \
            --enable-module=most \
            --enable-shared=max \
            --enable-module=so \
     >configure.log 2>&1
=ok
------------------------------
php-4.3.8
./configure \
     --prefix=/opt/WEB/php-4.3.8_compiled \
     --with-apxs=/opt/WEB/apache-1.3.31_compiled/bin/apxs \
     --with-informix=/opt/informix.se \
     --with-oci8=/opt/Oracle_10g/oracle/product/10.1.0/db_1 \
     --without-mysql \
     --enable-sigchild \
     --enable-memory-limit \
     --with-libxml-dir=/opt/WEB/libxml2-2.6.8_compiled \
     >configure.log 2>&1
=ok
Installing PHP SAPI module:       apache
[activating module `php4' in /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf]
cp libs/libphp4.so /opt/WEB/apache-1.3.31_compiled/libexec/libphp4.so
chmod 755 /opt/WEB/apache-1.3.31_compiled/libexec/libphp4.so
cp /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf.bak
cp /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf.new /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf
rm /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf.new
Installing PHP CLI binary:        /opt/WEB/php-4.3.8_compiled/bin/
Installing PHP CLI man page:      /opt/WEB/php-4.3.8_compiled/man/man1/
Installing PEAR environment:      /opt/WEB/php-4.3.8_compiled/lib/php/
[PEAR] Archive_Tar    - installed: 1.1
[PEAR] Console_Getopt - installed: 1.2
[PEAR] PEAR           - installed: 1.3.2
Wrote PEAR system config file at: /opt/WEB/php-4.3.8_compiled/etc/pear.conf
You may want to add: /opt/WEB/php-4.3.8_compiled/lib/php to your php.ini include_path
[PEAR] DB             - installed: 1.6.2
[PEAR] HTTP           - installed: 1.2.2
[PEAR] Mail           - installed: 1.1.3
[PEAR] Net_SMTP       - installed: 1.2.3
[PEAR] Net_Socket     - installed: 1.0.1
[PEAR] XML_Parser     - installed: 1.0.1
[PEAR] XML_RPC        - installed: 1.1.0
Installing build environment:     /opt/WEB/php-4.3.8_compiled/lib/php/build/
Installing header files:          /opt/WEB/php-4.3.8_compiled/include/php/
Installing helper programs:       /opt/WEB/php-4.3.8_compiled/bin/
  program: phpize
  program: php-config
  program: phpextdist

------------------------------------
php-5.0.1./configure \
     --prefix=/opt/WEB/php-5.0.1_compiled \
     --with-apxs=/opt/WEB/apache-1.3.31_compiled/bin/apxs \
     --with-informix=/opt/informix.se \
     --with-oci8=/opt/Oracle_10g/oracle/product/10.1.0/db_1 \
     --without-mysql \
     --enable-sigchild \
     --enable-memory-limit \
     --with-libxml-dir=/opt/WEB/libxml2-2.6.8_compiled \
     >configure.log 2>&1
=
Installing PHP SAPI module:       apache
[activating module `php5' in /opt/WEB/apache-1.3.31_compiled/conf/httpd.conf]
cp libs/libphp5.so /opt/WEB/apache-1.3.31_compiled/libexec/libphp5.so
cp: cannot stat `libs/libphp5.so': No such file or directory
apxs:Break: Command failed with rc=1
make: *** [install-sapi] Error 1
 [2010-12-20 10:25 UTC] jani@php.net
-Package: Tidy +Package: IMAP related
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 20:03:17 2021 UTC