php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29415 Autocompleting ignores "Enter" key.
Submitted: 2004-07-28 00:52 UTC Modified: 2005-09-22 13:48 UTC
From: annettetruong at yahoo dot com Assigned:
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: WinXP IE 6
Private report: No CVE-ID: None
 [2004-07-28 00:52 UTC] annettetruong at yahoo dot com
Description:
------------
Autocompleting ignores "Enter" key.
http://us3.php.net/search.php




Reproduce code:
---------------
First way
=========
1.) http://us3.php.net/search.php
2.) Enter "strpos" in the "search for" input box
3.) Hit "enter".

--> Nothing happens.

Second way
==========
1.) http://us3.php.net/search.php
2.) Enter "strp" in the "search for" input box
3.) Carefully use the down arrow until you highlight the "strpos" function name.
4.) Hit "enter".

--> Nothing happens.

Note: 
=====
This works (er...doesn't work) for any funtion. 
"strpos" is used for illustration.



Expected result:
----------------
When "enter" is hit, the "strpos" function page should be displayed.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-03 23:16 UTC] goba@php.net
Works for me with both your reproduce guides. What browser are you using? Can someone else verify this?
 [2004-08-04 00:07 UTC] annettetruong at yahoo dot com
IE 6.0 on Windows XP Professional (2002)
I just tried it again. The enter key is ineffective.
Thanks,
Annette.
 [2004-08-04 00:19 UTC] tomsommer@php.net
I can verify this in Internet Explorer. The enter key is not ignored, but the submission leads to a 404 page (apparently http://us3.php.net/search.php).

Cannot reproduce on other mirrors
 [2005-09-22 13:48 UTC] sniper@php.net
Works fine now. (apart from the fact that otherwise the autocompletion is buggy in IE, reported separately)

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 11:01:29 2024 UTC