php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29385 Soapserver always uses std class
Submitted: 2004-07-26 10:44 UTC Modified: 2004-11-16 13:18 UTC
Votes:10
Avg. Score:4.7 ± 0.6
Reproduced:8 of 8 (100.0%)
Same Version:6 (75.0%)
Same OS:1 (12.5%)
From: ron at ttvavanti dot nl Assigned: dmitry
Status: Closed Package: SOAP related
PHP Version: 5.0.0 OS: Debian GNU/Linux (2.4.22)
Private report: No CVE-ID:
 [2004-07-26 10:44 UTC] ron at ttvavanti dot nl
Description:
------------
SoapServer always seems to use std class on complex types. This way you can never get something like

class Foo { // some stuff on the class }

public function sendFoo(Foo $bar) { return $bar->doSomething(); }

to work. Because it will always cause a SoapFault (Argument 1 must be an instance of Foo).

If you would need more information, feel free to contact me.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-16 13:14 UTC] dmitry@php.net
Fixed in CVS HEAD and PHP_5_0.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 02:02:11 2014 UTC