php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29364 Causes compile failure
Submitted: 2004-07-24 13:50 UTC Modified: 2004-07-25 19:26 UTC
From: jwk at cbinc dot net Assigned:
Status: Not a bug Package: mnoGoSearch related
PHP Version: 4.3.8 OS: Redhat 9
Private report: No CVE-ID: None
 [2004-07-24 13:50 UTC] jwk at cbinc dot net
Description:
------------
When trying to compile PHP 4.3.8 or 5.0.0 with the mnogosearch extension (either the version with the stable tarball, the latest snapshot, or 1.91 from the mnogosearch.com website) the compile fails.

Reproduce code:
---------------
./configure --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-mcrypt --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --with-zlib --with-mnogosearch
make


Expected result:
----------------
To compile

Actual result:
--------------
It produces this error:
/usr/lib/mysql/libmysqlclient.a(net.o)(.text+0x990): first defined here
/usr/lib/mysql/libmysqlclient.a(net.o)(.text+0xc00): In function `net_request_file':
: multiple definition of `net_request_file'
/usr/lib/mysql/libmysqlclient.a(net.o)(.text+0xc00): first defined here
collect2: ld returned 1 exit status
make: *** [libphp4.la] Error 1

I ran configure without the --with-mnogosearch and it compiled and installed fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-25 19:26 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This error occurs due to a symbol conflict between the two 
underlying libraries, mysql & mnogosearch 
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 16:01:27 2021 UTC