php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29329 configure missing "-L$MYSQL_LIB_DIR" when checking for mysql_stmt_field_count
Submitted: 2004-07-22 15:53 UTC Modified: 2005-02-05 12:02 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: beardie at dsvr dot net Assigned:
Status: Closed Package: MySQLi related
PHP Version: 5.0.0 OS: Linux
Private report: No CVE-ID:
 [2004-07-22 15:53 UTC] beardie at dsvr dot net
Description:
------------
When running ./configure with the following options (amongst others):

  --with-mysql=shared,/opt/mysql-4.1
  --with-mysqli=shared,/opt/mysql-4.1/bin/mysql_config

I get the following failure message:

checking for mysql_stmt_field_count in -lmysqlclient... no
configure: error: MySQLI doesn't support versions < 4.1.3 anymore. Please update your libraries.

Which is resolved by applying the following patch to configure:

--- orig/configure      2004-07-22 14:27:15.000000000 +0100
+++  new/configure      2004-07-22 14:27:10.000000000 +0100
@@ -54963,7 +54963,7 @@
   echo $ac_n "(cached) $ac_c" 1>&6
 else
   ac_save_LIBS="$LIBS"
-LIBS="-lmysqlclient  $LIBS"
+LIBS="-L$MYSQL_LIB_DIR -lmysqlclient  $LIBS"
 cat > conftest.$ac_ext <<EOF
 #line 54969 "configure"
 #include "confdefs.h"
@@ -55196,7 +55196,7 @@
   echo $ac_n "(cached) $ac_c" 1>&6
 else
   ac_save_LIBS="$LIBS"
-LIBS="-lmysqlclient  $LIBS"
+LIBS="-L$MYSQL_LIB_DIR -lmysqlclient  $LIBS"
 cat > conftest.$ac_ext <<EOF
 #line 55202 "configure"
 #include "confdefs.h"



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-09 00:06 UTC] yrob at mail dot crpower dot com
Having the 'shared' statement didn't work at all for me.
Did not work: --with-mysqli=shared,/usr/local/mysql
Did work: --with-mysqli=/usr/local/mysql

Otherwise, I configured both mysql and mysqli using MySQL 5.0, but I get Segmentation faults while running scripts that contain mysql functions.  mysqli functions run just fine, however.  These are the specifications I used for configuring, which ran fine, so did the make and make install:
--with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config
 [2005-02-05 12:02 UTC] georg@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 17:01:54 2014 UTC