php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29194 "Amélie" turns into "Amélie" after simplexml_load_file()
Submitted: 2004-07-15 23:58 UTC Modified: 2004-07-21 23:00 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: tsigo at tsigo dot org Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 5.0.0 OS: Gentoo
Private report: No CVE-ID: None
 [2004-07-15 23:58 UTC] tsigo at tsigo dot org
Description:
------------
Example XML file:

<?xml version="1.0" encoding="us-ascii"?>
<Collection>
<DVD>
  ...
  <Title>Am&#233;lie</Title>
  ...
</DVD>
</Collection>

This is referring the movie "Amelie", and &#233 should turn into an accented 'e' (?), but instead it gets processed as "Amélie".

Reproduce code:
---------------
$Collection = simplexml_load_file($filename);
echo htmlentities((string) $Collection->DVD->Title); // Produces "Am&Atilde;&copy;lie"

Expected result:
----------------
Preserve the &#233; in the title.

Actual result:
--------------
Changes &#233; to é

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-21 21:38 UTC] kemps at free dot fr
It's seems that the output is utf-8 encoded.
I personnaly used a utf8decode($string_to_output).
Don't know if it is a bug or not ! (Francois)
 [2004-07-21 23:00 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This is not a bug, but a feature.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 11:05:54 2022 UTC