php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29157 'make install' of Apache 2 SAPI fails to prepend module path with leading slash
Submitted: 2004-07-14 18:09 UTC Modified: 2004-07-14 18:18 UTC
From: bjorn dot wiberg at home dot se Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.0.0 OS: Debian GNU/Linux 3.0.0r2 (mixed)
Private report: No CVE-ID: None
 [2004-07-14 18:09 UTC] bjorn dot wiberg at home dot se
Description:
------------
When running 'make install', the directive added to /etc/apache2/apache2.conf misses a leading slash (/) to the PHP 5 module.

I do not know if this is due to an error in apxs2 or in the way PHP 5's 'make install' calls it, but it has been around for quite some time now.


Furthermore, at least one other LoadModule directive must be present in /etc/apache2/apache2.conf before running 'make install', or apxs2 will fail to insert the line (it doesn't know where to put it), and the 'make install' fails. For this purpose I use:

# Commented-out dummy LoadModule directive to give apxs2 a hint
# about where to place new LoadModule directives (e.g. PHP)
#
# LoadModule dummy_module /usr/lib/apache2/modules/mod_dummy.so

That way, the PHP 5 LoadModule directive gets inserted right after the (commented-out) dummy line.

Reproduce code:
---------------
1. Configure PHP 5. I use the following directives:

./configure --enable-bcmath --enable-calendar --enable-dba --enable-dio --enable-embedded-mysqli --enable-exif --enable-ftp --enable-gd-native-ttf --enable-gd-jis-conv --enable-mbstring --enable-memory-limit --enable-pcntl --enable-shmop --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-wddx --enable-yp --enable-zend-multibyte --with-apxs2=/usr/bin/apxs2 --with-bcmath --with-bz2 --with-curl --with-db4 --with-freetype-dir=/usr/lib --with-gd --with-gettext --with-gmp --with-iconv --with-inifile --with-jpeg-dir=/usr/lib --with-ldap --with-libxml-dir=/usr/lib --with-mime-magic --with-mysql --with-mysql-sock --with-ncurses --with-openssl --with-png-dir=/usr/lib --with-pspell --with-snmp --with-tiff-dir=/usr/lib --with-ttf --with-xmlrpc --with-xpm-dir=/usr/lib --with-xsl --with-zlib --with-zlib-dir=/usr/lib

2. Compile PHP 5 with 'make'.
3. Run 'make install'.
4. View /etc/apache2/apache2.conf.

Expected result:
----------------
LoadModule php5_module /usr/lib/apache2/modules/libphp5.so


Actual result:
--------------
LoadModule php5_module        usr/lib/apache2/modules/libphp5.so


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-14 18:18 UTC] derick@php.net
This is an apxs2 problem, not ours.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 23:01:27 2024 UTC