|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29053 ./Configure --with-interbase
Submitted: 2004-07-07 20:17 UTC Modified: 2004-07-08 13:09 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: vieuxsinge at generation-net dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.3.7 OS: Mandrake 10.0 Athlon64
Private report: No CVE-ID: None
 [2004-07-07 20:17 UTC] vieuxsinge at generation-net dot com
I found the bug #28750, but 
I'm not sure that interbase .so who is broken ....

I try two day's ago to install php 4.3.3, or php 4.3.4, or php 4.3.7 with Interbase support
, on mandrake 9.2 for Athlon 64 or mandrake 10.0 Athlon64 with apache 2.0

When i make ./configure --with-interbase,

I've the same message has in the bug #28750 :

But libgds is on my system, and interbase run without any problem.

Then after read your message, i try with Firebird 1.5 and it's making
the same error ... :-(

I haven't this pb on older version of php
(Apache-AdvancedExtranetServer/2.0.44 (Mandrake Linux/11mdk) PHP/4.3.1)
(my second web server)

What do you mean about 'broken' interbase .so's

I hope you could help me , because i haven't find anything of this
problem on the net.

I think Interbase is better than mysql and it should be a very bad way to loose the interbase support in actual and futur php's versions ....

Sorry for my bad english.

Reproduce code:
configure: error: libgds, libib_util or libfbclient not found! Check
config.log for more information.

Expected result:
Have a good make file for compile my php with Interbase support :-)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-08 08:59 UTC]
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Don't file a NEW bug about this, add your comments to the old one. Duplicate of #28750.
 [2004-07-08 13:09 UTC] vieuxsinge at generation-net dot com
Ok , i'm sorry for have submit a new bug,but this is not really the same bug as the description in 28750, because after one night of tests, it's possible to install PHP 4.3.4 with Interbase or Firebird, without any problem, but on a 32 Bits's sytem (Mandrake 10.0 32 Bits).

But , for FireBird, you must install an older version that 1.5 (i have make test with 1.0.x ) because in the package of the 1.5 version of firebird , there isn't the , then it's making the bug discribe in 28750

Then the really problem is to compile php on a 64 Bits 's system, I'm thinking it's a problem in the disk architecture of /usr/lib and /usr/lib64 on mandrake for 64 bits.

I tried to make symbolic links, without any solution ....

After this night my english isn't better than the last day :-)

Thanks a lot for your insteresting of this probleme, because it's very important to me to have a solution.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 02:01:28 2024 UTC