php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29007 glob() nomatch returns false
Submitted: 2004-07-04 09:43 UTC Modified: 2005-01-24 10:45 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (100.0%)
From: mplomer at gmx dot de Assigned:
Status: Closed Package: Directory function related
PHP Version: 5CVS-2004-07-04 (dev) OS: WinXP
Private report: No CVE-ID: None
 [2004-07-04 09:43 UTC] mplomer at gmx dot de
Description:
------------
Same as Bug# 28649.
It seems to be fixed only in 4.x-CVS
With the actual 5.0-CVS-Snapshot I have the same Problem.

Reproduce code:
---------------
php -r 'var_dump(glob("abcdefg"));'

Expected result:
----------------
an empty array()

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-24 10:43 UTC] hholzgra@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2005-01-24 10:45 UTC] hholzgra@php.net
I only tested on Linux, please reopen if it persists on WinXP
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 06:23:17 2021 UTC