php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28983 Oracle OCILogon function crashes apache
Submitted: 2004-07-01 14:55 UTC Modified: 2004-07-08 08:55 UTC
Votes:9
Avg. Score:3.8 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:4 (100.0%)
From: dfe-csi dot gips at ti dot ch Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.3.6 OS: Windows 2000 server
Private report: No CVE-ID: None
 [2004-07-01 14:55 UTC] dfe-csi dot gips at ti dot ch
Description:
------------

Description:
-----------------------------------------------
Our webserver works on a oracle 8.1.7 database 
trought the oci8 php extension.

We observe (with apache server-status module) 
that the apache process isn't stable 
and reboots frequently (up to 50times/day).

Each crash causes a Dr. Watson dump (Exception 
number: c0000005 - access violation)

We can reproduce the crash on calling a simple 
OCILogon function with 5 concurrent users.

Tested Issues:
- Upgading the oracle client from 8.1.7 to 9.2.0 
  and 10.1.0 we have longer uptime but crashes anyway.
- Using TNS address string in OCILogon (like 
  BUG# 26558 suggestion) makes less core dumps.
- We could not reproduce the error with PHP/Linux 
  using the same hardware. 

We currently wonder if this could be an issue
with PHP/Oracle running on a Multiprocessor 
Windows server?

Sysconfig:
-----------------------------------------------
Compaq Proliant DL360 (Dual Processor);
Windows 2000 server SP 4, 
Apache 1.3.29,
PHP 4.3.6 (apache module)
Oracle client 10.0





Reproduce code:
---------------
<?php

  if ($c=OCILogon("user", "pass", "host")){
    print "OCILogon success";
    OCILogoff($c);

  } else {
    print "OCILogon failed";

  }

?> 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-01 15:09 UTC] dfe-csi dot gips at ti dot ch
how can i attach the zipped drwtsn32.log ? (22KB)

Diffs of php.in vs php.ini-dist
-----------------------------------------------
asp_tags           = On
max_execution_time = 120
log_errors         = On
error_log          = "C:\temp\php_error.log"
register_globals   = On
default_mimetype   = "text/html"
default_charset    = "iso-8859-1"
include_path       = ".;D:\www;D:\www\myapp"
extension_dir      = "C:\apache\php\extensions"
extension          = php_fdf.dll
extension          = php_oci8.dll
extension          = php_pdf.dll
SMTP               = mymailhost.example.com
sendmail_from      = myemail@example.com
session.save_path  = "C:\temp\sessions"
session.auto_start = 1
===============================================
 [2004-07-01 16:04 UTC] dfe-csi dot gips at ti dot ch
Get the Dr.Watson dump file at the following address:

http://www2.gips.ti.ch/drwtsn32.zip

(File size: 22 KB "zipped"; 141 KB "unzipped")
 [2004-07-01 17:34 UTC] luth at ch dot ibm dot com
I have reproduced this problem with oracle10g / php 4.7 / apache 2.0 - on a windows xp box with an intel Hyperthreading CPU ("multiprocessor" system too). 
Using 10 concurrent users doing repeatedly logon, after 8 minutes I do get the address violation, the stack trace points to oracle10.dll.
 [2004-07-02 01:03 UTC] luth at ch dot ibm dot com
I repeated the test above while turing *off* Hyperthreading (which makes it a singleprocessor system) and the problem is gone!
 [2004-07-02 09:05 UTC] derick@php.net
Marking as "bogus" as it's an exact duplicate of #28403.
 [2004-07-05 16:19 UTC] dfe-csi dot gips at ti dot ch
Hi derick-at-php-dot-net,

thank you for answer.
We agree with the decision to link it to bug #28403, 
but this one has status 'suspended' since july, 1st.

Is this correct or is it possible to change status to 'open' ?

Cheers,
Marc
 [2004-07-07 17:37 UTC] dfe-csi dot gips at ti dot ch
Hi derick,
pls answer previous comment. 

Thanks,
Marc

-> setting bug to "open".
 [2004-07-08 08:55 UTC] derick@php.net
That is correct, it is set to suspended.
 [2004-09-15 14:25 UTC] jaykrv at hotmail dot com
How can be link the PDF / Image (GID) Libraries to Apache/PHP/MySQL/WindowsNT ?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 06:05:46 2022 UTC