|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28967 enabling pspell causes apache to crash, segmentation fault
Submitted: 2004-06-30 05:40 UTC Modified: 2004-07-11 20:28 UTC
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: shannon at swerb dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.3.7 OS: Freebsd 4.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: shannon at swerb dot com
New email:
PHP Version: OS:


 [2004-06-30 05:40 UTC] shannon at swerb dot com
Hi there, sorry, but I am running out of ideas here...
I have tracked my problem to similar to the bugs 17402 or 8133 or 8464.  I have tried php 4.3.4 through 4.3.7 including latest snapshot.  My configure options are:
'./configure' '--with-mysql' '--with-apxs=/usr/local/apache/bin/apxs' '--includedir=/usr/local/include' '--with-pspell' '--with-xml' '--with-zlib' '--with-mcrypt=/usr/src/libmcrypt-2.5.7' '--enable-memory-limit=yes' '--enable-shmop' 
I have also tried various other configurations, the common configure option is always pspell.  If I remove it the issue goes away...
The issue is that the so module is installed and then I can start apache standard and with ssl, but cannot do a restart or a graceful without getting a seg fault and core dumped, can't figure out what is going on here. i have updated my glib, gmake functions, I have used various version of aspell, all with no luck.  No matter what I try I cannot get the pspell module enabled and to allow apache to do a restart or graceful without a core dump.
I am using apache 1.3.27.
Thanks for your help!
Best Regards,


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-01 04:06 UTC] shannon at swerb dot com
The following gdb session produced the backtrace from the httpd.core...

batt3# gdb /usr/local/apache/bin/httpd /usr/local/apache/httpd.core
GNU gdb 4.18 (FreeBSD)
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-freebsd"...
(no debugging symbols found)...
Core was generated by `httpd'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/ debugging symbols found)...
Reading symbols from /usr/lib/ debugging symbols found)...done.
Reading symbols from /usr/local/lib/php/phpa/
(no debugging symbols found)...done.
Reading symbols from /usr/libexec/ debugging symbols found)...
#0  0x0 in ?? ()
(gdb) bt
#0  0x0 in ?? ()
#1  0x28519319 in _init ()
   from /usr/local/lib/php/phpa/
#2  0x28524595 in _fini ()
   from /usr/local/lib/php/phpa/
#3  0x280c6e59 in find_symdef () from /usr/libexec/
#4  0x28171f94 in exit () from /usr/lib/
#5  0x80781bc in clean_parent_exit ()
#6  0x807b529 in main ()
#7  0x804f905 in _start ()
 [2004-07-01 07:05 UTC]
confirmed problem with php accelerator, not php.
 [2004-07-07 04:09 UTC] shannon at swerb dot com
I am not convinced the PHP team should not look into this further.  I have tried this a number of ways, and I can use the accelerator no problem as long as i don't enable the pspell support?  I have tried all version from 4.3.4 through the latest CVS, as well, have tried various other modules, upwards of adding another 30 --with options in the configure script, all are ok but as soon as --with-pspell added it causes the fault...  Is it possible that this is a PHP issue and not an accelerator issue?

At any rate, the accelerator folks at phpa don't seem to be supporting their product so I hope this helps others with the same problem and choose to disable and attempt to go with another accelerator/cache solution.

If the php folks still deam this "Bogus" and close it then I'll let it slide, but it seems quite odd to me.

 [2004-07-11 20:28 UTC]
If you can reproduce it with some other cache/accelerator, reopen.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 23 11:01:30 2024 UTC