php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28942 PHP has encountered an Access Violation
Submitted: 2004-06-28 10:21 UTC Modified: 2004-06-29 17:58 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: reha at bilgiparki dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.3.7 OS: Windows 2000 Server
Private report: No CVE-ID: None
 [2004-06-28 10:21 UTC] reha at bilgiparki dot com
Description:
------------
When calling a webpage, it says "PHP has encountered an Access Violation at 01907A6D" within anywhere of the page.

Windows 2000 Server
IIS5 
PHP 4.3.7
Running as ISAPI module 

In my opinion, this type of fatal errors should be going to the Event Log instead of displaying to users.

Reproduce code:
---------------
<?
 echo "IP Adresiniz :"
 echo $_SERVER["REMOTE_ADDR"]
?>

Expected result:
----------------
IP Adresiniz : 81.213.98.71PHP has encountered an Access Violation at 01907A6D


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-28 10:40 UTC] reha at bilgiparki dot com
I have realised that when i have included session_start() function into my code, it doesn't give me any error..

Code 1:
-------
URL : http://www.bilgiparki.com/test.php
<? 
echo "test";
?>

The result as:
testPHP has encountered an Access Violation at 01907A6D

Code 2:
-------
URL : http://www.bilgiparki.com/test1.php
<? 
session_start();
echo "test";
?>
The result as:
test

As you see that, when i have added session_start(), the problem seems to solved.
 [2004-06-28 11:04 UTC] reha at bilgiparki dot com
Dear Php team, sorry for my spam messages but, i have found something it may be releated to this error.

In my other domain, i have this code:	
<? 
ob_start();
echo "test";
?>

and i have realised to forgot to flush code. Anyway, here is new code;
<? 
ob_start();
echo "test";
ob_end_flush();
?>

after running this code, everything is corrected. But before running the code, to correct this problem i have added session_start() into whole my php pages.
 [2004-06-29 17:58 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #28898 
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 07:01:26 2021 UTC