php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28929 PHP has encountered an Access Violation at 015B73DD
Submitted: 2004-06-25 19:45 UTC Modified: 2004-07-22 01:04 UTC
Votes:31
Avg. Score:4.8 ± 0.4
Reproduced:28 of 29 (96.6%)
Same Version:20 (71.4%)
Same OS:21 (75.0%)
From: remy at ourselves dot nl Assigned:
Status: Closed Package: IIS related
PHP Version: 5CVS-2004-06-25 (dev) OS: Win XP Pro
Private report: No CVE-ID: None
 [2004-06-25 19:45 UTC] remy at ourselves dot nl
Description:
------------
Clean default install of Win XP Pro. Then installed IIS5.1,the .NET Framework, an SQL-server instance and Java. Run Windows Update and installed every patch.

Then installed PHP5.0RC3 (without a php.ini) and then every page parsed by PHP I get at the end the following line:
PHP has encountered an Access Violation at 015B73DD

Then renamed php.ini-dist to php.ini and restarted IIS, but the same problem occurs.

Then stopped IIS and installed the latest snapshot of PHP (25june2004 14:00), also without a php.ini, and the same problem occurs.



Reproduce code:
---------------
<?php phpinfo(); ?>

Expected result:
----------------
You can look at the phpinfo (with the bug at the end) at http://reasonsto.servebeer.com/phpinfo.php.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-06 17:34 UTC] remy at ourselves dot nl
I installed the latest release (06-Jul-2004 16:49), but I'm still getting an error after each parsed page by IIS5.1, as can be seen on here:
http://reasonsto.servebeer.com:81/phpinfo.php5

Same IIS, but using latest release of PHP4, can be seen here:
http://reasonsto.servebeer.com:81/phpinfo.php

I installed Apache2, so that I could use PHP5. Apache with PHP5.0RC3 on the same server (with the same phpfile), can be found here:
http://reasonsto.servebeer.com/phpinfo.php (or .php5)

I you need more info, please let me know.
 [2004-07-14 19:42 UTC] remy at ourselves dot nl
One other problem (don't know if this is related) is that I want to use some extensions, but they are not working (For  Apache2 AND IIS5.1!).

I load php_mssql.dll, php_tidy.dll and php_pdo.dll(PECL) without any errors (paths are correct), but there functions\class are not availeble and don't show up in phpinfo() (see links above).

R?my
 [2004-07-15 23:04 UTC] mdobrev at gmail dot com
I'm having the same problem with the final version. The extensions are not loading at all. Only the CLI version is functioning for me.
 [2004-07-16 20:57 UTC] daseymour at 3hc dot org
Same problem here (PHP has encountered an Access Violation at 011573CD).  Running Windows 2000 5.00.2195, PHP 5.0.0, and IIS 5.0.
 [2004-07-21 11:12 UTC] mattbta at gmail dot com
Same error - different memory address...however - here's the kicker, only search engine spiders see it.  I can't reproduce the error in any browser on windows, but going through search engine simulators, the error pops up in different spots on different pages.  This only seems to be related to pages with MySQL connections/queries.

Setup - w2k3, IIS6, PHP5.0.0 ISAPI, MySQL 4.0.18

Running the same pages on different port with Apache 2.50 eliminates the error.

I've given the IUSR_COMPUTERNAME account full control to the php dir, mysql dir, web dir, and php/mysql dll's in %systemroot% and system32 and system.
 [2004-07-22 01:04 UTC] edink@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2004-07-30 07:24 UTC] sak_cu at hotmail dot com
I you CVS version both php and pecl
I has no error

When I restart "IIS Admin"
error dialog will appear.
But it can restart without problem
and webserver can run normally...

This is php bug or IIS Admin bug??
 [2004-07-30 16:48 UTC] g dot collins8 at ntlworld dot com
I am running win 2000 server IIS 5 with php 5.0.0 & MySql 4.0.20d

http://www.nx99.net/info.php

I do not seem to have an error on this page however when I try to install phpmyadmin or vBulletin I get the following erro.

PHP has encountered an Access Violation at 019573CD

What can i do to fix this as I can not get anything to work.
 [2004-09-06 05:08 UTC] Ersan191 at evilxp dot com
This bug only seems to occur when running php in isapi mode through IIS.  I get this error 50% of the time with php4isapi.dll, but when I restart IIS it goes away for awhile.
 [2010-06-11 19:12 UTC] in2ishun at yahoo dot com
***************** SOLUTION!!!!


I realize this issue is AGES old, but it still manages to be the top hit on Google searches as of now (6/2010).

I fixed my own instance of seeing this error. W2k3, IIS6, PHP 5.2.6, MySQL 5.1.

The problem is in the pathing. When I used the MSI installer for MySQL without doing an "advanced" installation (where I could manage the install details), it added a path to the system environment that contained spaces. Even after changing the path environment to use the Windows short-name location of the mysql bin directory, it still didn't work.

The solution was for me to reinstall mysql and set the default installation path to just off the root (e.g. C:\mysql). Once I did that the error went away and my app started working.

There are a number of sites with a variety of potential solutions to this issue and several of them mentioned paths and the "libmysql.dll" file (in the "bin" directory of your mysql installation).

If this helps you solve your problem, consider leaving a comment here so others can see that it works.
 [2010-07-15 21:34 UTC] jonwitts at gmail dot com
I resolved this one by making sure that MySQL Path entry for windows was the last in the list, or at least after the PHP path entry...

Hope it helps someone...
 [2010-10-25 22:50 UTC] robertbain2001 at gmail dot com
That's it! Simply making the mysql bin entry first, in the PATH environment variable, solved my problem.

Thanks a million. Re-installing mysql would not have been a practical solution.

-Robert
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Sep 25 23:01:25 2018 UTC