php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #28877 The First 4 letters missing When Post
Submitted: 2004-06-22 03:01 UTC Modified: 2015-01-08 23:04 UTC
From: jli at pegasuspharm dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 4.3.6 OS: MS Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jli at pegasuspharm dot com
New email:
PHP Version: OS:

 

 [2004-06-22 03:01 UTC] jli at pegasuspharm dot com
Description:
------------
The First 4 letters missing with the following codes When Post:(Note: the text fileds below is an array like desc[])  

<form name="service" method="post" action="<?php $_SERVER["PHP_SELF"]; ?>" onSubmit="return checkEnter();">
<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][0]; ?>">

<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][1]; ?>">

<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][2]; ?>">

</form>

Reproduce code:
---------------
<form name="service" method="post" action="<?php $_SERVER["PHP_SELF"]; ?>" onSubmit="return checkEnter();">
<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][0]; ?>">

<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][1]; ?>">

<input name="Desc[]" type="text" size="40" maxlength="50"  value="<?php echo $_POST["Desc"][2]; ?>">

</form>

Actual result:
--------------
The first 4 letters provided in a field missing.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-22 03:21 UTC] scottm at spamcop dot net
Can you confirm your php version as this sounds like a bug in php 4.2.3

See
http://bugs.php.net/bug.php?id=19404
 [2015-01-08 23:04 UTC] ajf@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 [2015-01-08 23:04 UTC] ajf@php.net
Duplicate of: https://bugs.php.net/bug.php?id=19404

(Which was fixed.)
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC