php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19404 Post variable names stripped of first 4 characters
Submitted: 2002-09-14 08:55 UTC Modified: 2003-10-04 06:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mv02 at gmx dot de Assigned:
Status: Closed Package: mbstring related
PHP Version: 4.2.3 OS: SuSE Linux 8.0
Private report: No CVE-ID:
 [2002-09-14 08:55 UTC] mv02 at gmx dot de
Since I'm using PHP 4.2.3 phpMyAdmin (http://www.phpmyadmin.net) does not work properly anymore. To me it seems as if string routines would be broken. As an example I have two errormessages generated from phpMyAdmin:

Creating a simple table with ID as auto_increment:

--
CREATE TABLE `atest` (

`ID` INT NULL _INCREMENT,
PRIMARY KEY ( `ID` ) 
) 

MySQL meldet: 


You have an error in your SQL syntax near '_INCREMENT, PRIMARY KEY (`ID`))' at line 1
--

It seems as if this PHP version would kill the "auto" in front of "_increment". Of course, then MySQL produces an error.

Second example: If I change a value (DATE), I get the following error:

--
UPDATE `termine` SET `datum` = '-09-23' WHERE `ID` = \'42\' LIMIT 1; 

MySQL meldet: 


You have an error in your SQL syntax near '\'42\' LIMIT 1' at line 1
--

There is one ' too much (changing MagicQuotes did not help anything)

I do not thing that this is a problem of phpMyAdmin because I just recompiled PHP 4.2.2 with exactly the same configure options on the same system (2 days difference, so no new libraries etc) and everything works just perfect.

My confiugure Line:
--
'./configure' '--prefix=/usr/share' '--datadir=/usr/share/php' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--with-config-file-path=/etc/httpd' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-memory-limit' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-bz2' '--with-ftp' '--with-gdbm' '--with-gettext' '--with-gmp' '--with-imap=yes' '--with-jpeg-dir=/usr/lib' '--with-ldap=yes' '--with-mcal=/usr' '--with-mcrypt' '--with-mysql=/usr' '--with-ndbm' '--with-pgsql=/usr' '--with-snmp' '--with-t1lib' '--with-ttf' '--with-freetype-dir=yes' '--with-zlib=yes' '--with-openssl' '--with-curl' '--with-imap-ssl' '--with-gd=yes' '--with-mm' '--with-apxs=/usr/sbin/apxs' '--with-ming' '--with-mhash' '--with-pdflib' '--with-png-dir=/usr/lib' '--with-tiffs-dir=/usr/lib' '--with-iodbc'
--
I do not include a backtrace because PHP does not crash at all. The system continues to run, the page gets finished and I can continue to work with PHP.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-14 11:32 UTC] wez@php.net
This was a problem with mbstring that has been fixed in CVS.
The workaround is not to use --enable-mbstr-enc-trans
when configuring PHP. (You won't miss it, because the
chances are that you don't even know what it does :-)
 [2002-10-12 10:51 UTC] khalil at paksys dot com
This is the same issue which was reported here http://bugs.php.net/bug.php?id=19460
I was advised to take latest PHP from CVS. I did and the problem was solved.
 [2002-12-01 09:40 UTC] msopacua@php.net
To anybody who wants to post phpMyAdmin bugs here:
- phpMyAdmin is NOT part of php
- phpMyAdmin has it's own bug system, read the README.
- the original report involved a bug in mbstring

changed title, to reflect the actual bug.
 [2003-11-14 03:39 UTC] amal at npeople dot com
I can't run phpMyAdmin on my signiture hosting server
(./libraries/grab_globals.lib.php)failed to open stream: No such file or directory in /usr/home/majd/www/htdocs/phpMyAdmin/index.php on line 9

My phpMyAdmin version is 2.5.4
 [2010-04-30 18:19 UTC] spam1 at yahoo dot com
<a href="http://weddingsite.110mb.com/pictures-of-wedding-card-boxes.html">pictures of wedding card boxes</a> [URL=http://weddingsite.110mb.com/collisions-wedding-stationery.html]collisions wedding stationery[/URL] http://weddingsite.110mb.com/wedding-cake-boxes.html wedding cake boxes
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 14:02:18 2014 UTC