php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28867 Variables not being passed on form post
Submitted: 2004-06-21 16:12 UTC Modified: 2004-07-08 16:27 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: matt at atopia dot net Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.3.7 OS: FreeBSD 4.10
Private report: No CVE-ID: None
 [2004-06-21 16:12 UTC] matt at atopia dot net
Description:
------------
This was originally posted as a mozilla firefox bug, and left open for a good 9 months until today...

http://bugzilla.mozilla.org/show_bug.cgi?id=215479

Seems it has been described as a bug in PHP...

Originally, the problem I was experiencing last September was the following:

After HTTP authentication, both variables (PHP_AUTH_USER and REMOTE_USER) would be set until I submitted a form that used method=post.  After that, neither variable would be set until I visited a page using GET (not post).  Then, both variables would reset themselves (I assume because the browser posts the username/pass each request with HTTP authentication).

Originally, the problem occured with HTTP and HTTPS, so I have setup two different test cases.

As of now, I am currently experiencing this problem still, but only with the REMOTE_USER variable.  A new version of PHP seems to have fixed the PHP_AUTH_USER problem. (this will all be shown in the test case).



Reproduce code:
---------------
http://www.atopia.net/test/mozbug215479/step1.php
https://secure.webaries.com/atopia/test/mozbug215479/step1.php

User/Pass: test/test

Source code is available for both of the files by replacing .php with .source 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-25 16:07 UTC] edink@php.net
I have just tested this and the bug cannot be reproduced on Linux with nearly the same configuration.

Could you please append phpinfo() at the end of step2.php so that we can have a look at possible configuration differences.

Also plase post your php.ini on your site.
 [2004-06-25 16:25 UTC] matt at atopia dot net
PHP Info At:

http://www.atopia.net/test/mozbug215479/displayinfo25472358158709325.php

user/pass: test/test

php.ini is same as php-dist.ini in the source.
 [2004-07-06 15:53 UTC] sniper@php.net
I can't reproduce either. Does this happen with ANY browser?
(something else than Mozilla, like IE..:)

 [2004-07-06 16:54 UTC] matt at atopia dot net
I just tested using Internet Explorer 6 and Mozilla Firefox .9.... problem exists in both.  Tried on 10 different computers as well (I'm in a lab).

-Matt
 [2004-07-06 16:55 UTC] matt at atopia dot net
Please check out the source of my test case (has been included in the original post).
 [2004-07-08 11:54 UTC] sniper@php.net
Looks like it's either:

a) configuration mistake done by you.
b) Some bug in Apache when you configure it some weird way.

(not PHP bug as I can't reproduce this either on my own machine, but it's Linux where everything usually works anyway :)

 [2004-07-08 16:27 UTC] matt at atopia dot net
Did you try copying those scripts i posted to your own server and running them?  Cause I just copied them to another server with different config and its still occuring :-(
 [2004-08-06 05:30 UTC] vze55yfg at verizon dot net
I am receiving the same thing on my XP machine.  It's driving me up the wall!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 07:03:34 2021 UTC