php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2885 can not resolve open64
Submitted: 1999-12-01 11:23 UTC Modified: 1999-12-01 11:30 UTC
From: pa_wilki at gene dot concordia dot ca Assigned:
Status: Closed Package: MySQL related
PHP Version: 3.0.12 OS: Slackware 3.x
Private report: No CVE-ID: None
 [1999-12-01 11:23 UTC] pa_wilki at gene dot concordia dot ca
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol 'open64'
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol '__lxstat64'
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol 'fopen64'
Syntax error on line 238 of /csfg/NET/httpdphp/conf/httpd.conf:
Cannot load /csfg/NET/httpdphp/libexec/libphp3.so into server: Unable to resolve symbol
-----

linking php as a dynamic module seems to produce this error. It also appears when compiling php into apache as a regular module following the instructions given in the manual.

I assume that this has something to so with the filesystem and messages sent to the compiler which give the linker a problem. The mailing lists were not much help. The only suggestion was to upgrade mysql to version 3.22.25 ... but I am working with 3.22.27 binary on a pentiumIII.

php does compile just fine, mysql is a binary. Apache compiles with no trouble with the dynamic module. However make does fail with apache when apache is compiled as a non-dynamic module.

here is the configure line:

./configure --with-apxs=/csfg/NET/httpdphp/bin/apxs \
--with-system-regex \
--with-gd=/usr/local/lib \
--with-mysql=/usr/local/mysql \
--with-zlib=/usr/local/lib \
--with-pdflib=/usr/local/lib \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--with-config-file-path=/csfg/NET/phpconf \
--with-exec-dir=/csfg/NET/php_safe_exec --enable-short-tags=no


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-01 11:30 UTC] sas at cvs dot php dot net
This is not a PHP bug.

The MySQL binaries were linked against glibc-2.1, thus you need glibc-2.1 to use them. Possible solutions:

- compile MySQL yourself
- upgrade your system to glibc-2.1

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 00:01:25 2019 UTC