php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28701 MySQLi and MsSQL extensions are missing with PHP5 RC3
Submitted: 2004-06-08 19:09 UTC Modified: 2004-06-09 17:13 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: Robin at RHarmsen dot nl Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5CVS-2004-06-08 (dev) OS: Windows
Private report: No CVE-ID: None
 [2004-06-08 19:09 UTC] Robin at RHarmsen dot nl
Description:
------------
The PHP version is actualy RC3, but it also is in the latest CVS version.

the php_MySQLi.dll and php_MSSql.dll are missing form the release.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-08 19:10 UTC] Robin at RHarmsen dot nl
The DLL's are missing from the Windows Release

ow and libMySQLi.dll is missing to
 [2004-06-08 23:32 UTC] phpbug at zulan dot net
I have encountered the same problem.
Just wanted to test if mysqli class has been made final or extend-able.
I would be very pleased if this will be fixed since the old versions are not able to be loaded aswell.
 [2004-06-08 23:39 UTC] amt@php.net
If I read the CVS commit log correctly, the MySQLi class should now be extendable. Download a snapshot from http://snaps.php.net to check. (I don't actually know if the libmysqli.dll is included in the snaps, but it's a place to start.)
 [2004-06-08 23:43 UTC] Robin at RHarmsen dot nl
The last one that is online
Built On: Jun 07, 2004 14:30 GMT

doesn't have the MySQLi dlls anymore, so something went wrong somewhere... perhaps with the change you mention
 [2004-06-09 09:36 UTC] derick@php.net
Nothing is wrong; the extension now requires libmysql 4.1.2 and because MySQL doesn't provide those libraries for windows we can't compile the extension anymore.
 [2004-06-09 10:07 UTC] Robin at RHarmsen dot nl
So this means we will never be able to use MySQLi anymore on the Windows platform?
 [2004-06-09 10:13 UTC] derick@php.net
That's up to MySQL AB whether they want to provide us with those libs and headers.
 [2004-06-09 14:50 UTC] sfox@php.net
php_mssql.dll is now available from snaps.php.net.
 [2004-06-09 17:02 UTC] edink@php.net
So is php_mysqli.dll thanks to sfox@php.net.
 [2004-06-09 17:05 UTC] sfox@php.net
php_mysqli.dll and libmysqli.dll are now both available via snaps.php.net

Note that this supports mysql 4.1.2 alpha, as mentioned by Derick earlier.

Extensibility is getting there :)
 [2004-06-09 17:13 UTC] Robin at RHarmsen dot nl
Great :D

So this bug can be closed :)
 [2004-06-09 19:24 UTC] raomi at mail dot com
Fine that it is fixed now but why was not even a changelog entry about this problem.
I would appreciate a news post and an updated RC3 binary on the downloads page to avoid others running into this problem.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 05:05:53 2022 UTC