php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28698 Wrong upload command
Submitted: 2004-06-08 15:43 UTC Modified: 2004-06-08 15:52 UTC
From: ed dot white at libero dot it Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.4 OS: FreeBSD
Private report: No CVE-ID: None
 [2004-06-08 15:43 UTC] ed dot white at libero dot it
Description:
------------
The PHP function ftp_put() send a STOR command to the FTP 
server. The problem is that very few servers support it. 
 
Today the right command to upload files is PUT. 
 

Reproduce code:
---------------
Use the example on the manual page. It contains a complete script to upload a file. Test it with a Linux/BSD/unix ftp servers and see no good results.

I haven't any Windows ftp servers to test.

Expected result:
----------------
upload a file with PUT.  

Actual result:
--------------
Warning: ftp_put(): 'STOR': command not understood. in 
/usr/home/ed/src/update-stocklist.php on line 34 
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-08 15:47 UTC] ed dot white at libero dot it
Sorry, I'm dumb... 
 
All ok with STOR. 
PUT is used by ftp clients. 
 
Ops.
 [2004-06-08 15:52 UTC] derick@php.net
Ok, marking bogus then.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 13:03:35 2022 UTC