php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28587 Default 16-bit Color has Little Square Dots Everywhere
Submitted: 2004-05-31 06:29 UTC Modified: 2008-03-07 02:06 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: jbelton at shaw dot ca Assigned:
Status: Closed Package: PHP-GTK related
PHP Version: 1.0.0 (PHP-GTK) OS: Windows 98
Private report: No CVE-ID: None
 [2004-05-31 06:29 UTC] jbelton at shaw dot ca
Description:
------------
Just installed PHP-GTK 1.0.0 on Windows 98.  Don't know the version of PHP.  Downloaded the hello world script below.  Works fine, but the default "color" is light grey, covered with dark grey dots.  Also downloaded a longer sample program.  Again, works fine but with little grey dots all over it.

Reproduce code:
---------------
<?php

if (!class_exists('gtk')) {
    if (strtoupper(substr(PHP_OS, 0,3) == 'WIN'))
    dl('php_gtk.dll');
  else
    dl('php_gtk.so');
}

function delete_event()
{
    return false;
}

function shutdown()
{
    print("Shutting down...\n");
    gtk::main_quit();
}

function hello()
{
    global $window;
    print "Hello World!\n";
    $window->destroy();
}

$window = &new GtkWindow();
$window->connect('destroy', 'shutdown');
$window->connect('delete-event', 'delete_event');
$window->set_border_width(10);

$button = &new GtkButton('Hello World!');
$button->connect('clicked', 'hello');
$window->add($button);

$window->show_all();

gtk::main();

?>


Expected result:
----------------
A little window with a button saying hello world, but without little dark grey spots all over it.

Actual result:
--------------
Could send a screen shot, 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-31 12:21 UTC] derick@php.net
Recategorizing.
 [2004-05-31 14:30 UTC] epplestun at alaplaya dot com
This is not a bug, that is the color of the GTK interface, if you try to use the GTK themes your interface change
 [2004-06-01 04:54 UTC] jbelton at shaw dot ca
Couldn't the default be just plain grey?  This seems to be the default for every other windows app.  Having a default of "psychosis inducing graph paper" that requires developers to figure out how to install and modify the default theme doesn't seem like a great way to win over the windows development community.  But what do I know, I'm a Linux developer >;)
 [2004-06-05 01:03 UTC] jbelton at shaw dot ca
Determined that this is not a problem if the display mode is set to 32-bit color rather than 16-bit.  Unfortunately, some Windows software doesn't work in 32-bit, so this is still a problem.
 [2008-03-07 02:06 UTC] auroraeosrose@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 22:01:26 2019 UTC