php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28530 postfix x mail()
Submitted: 2004-05-26 17:19 UTC Modified: 2004-05-27 15:18 UTC
From: antonio@php.net Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.6 OS: FreeBSD 4.10-PRERELEASE
Private report: No CVE-ID: None
 [2004-05-26 17:19 UTC] antonio@php.net
Description:
------------
mail() is not sending mails correctly using postfix

Reproduce code:
---------------
<?php mail('foo@bar.org', 'foo', 'bar'); ?>

Expected result:
----------------
May 26 10:57:51 <machine> postfix/cleanup[50047]: 3D1A43B0: to=<foo@bar.org> (...)

Actual result:
--------------
May 26 10:57:51 <machine> postfix/cleanup[50047]: 3D1A43B0: to=<unknown>, relay=none, delay=0, status=bounced (No recipients specified)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-26 17:46 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2004-05-26 21:25 UTC] antonio@php.net
Cenario: FreeBSD 4.10, Apache 1.3.31, PHP 4.3.6 and postfix.

When we try to execute that code (even on console), the mail is not being sent to the destination mail because - for some strange reason - mail() is sending an empty RCPT TO to postfix.

I've tested using sendmail (another machine with same cenario, except for postfix) and the mail goes ok.
 [2004-05-27 15:18 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

I am pretty sure the problem is with postfix not PHP since 
the code for piping an e-mail is the same. 
 
You can try to strace the cli script used to send the 
e-mail to see what exactly PHP sends to postfix. 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 19:05:43 2022 UTC