php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28527 Sorting arrays in utf-8 charset not possible
Submitted: 2004-05-26 14:06 UTC Modified: 2004-05-26 17:40 UTC
From: marek at lewczuk dot com Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5CVS-2004-05-26 (dev) OS: Windows XP
Private report: No CVE-ID:
 [2004-05-26 14:06 UTC] marek at lewczuk dot com

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-26 14:21 UTC] derick@php.net
PHP sorts according to ascii, not a charset so this is not a bug. You will need to use usort() and strcoll() to get this to work.

Not a bug -> bogus.
 [2004-05-26 17:04 UTC] marek at lewczuk dot com
Ok, so lets try to do it with usort() and strcoll(). Strcoll() isn't working at all - it always return 2147483647. So
 [2004-05-26 17:07 UTC] marek at lewczuk dot com
Sorry. You are right. The problem was in not-proper setLocal settings. It is working with usort and strcoll. Sorry for "bogus".
 [2004-05-26 17:40 UTC] marek at lewczuk dot com
Sorry again - it is not working. I have created new bug.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 19:01:53 2014 UTC