php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28514 POST variables not set
Submitted: 2004-05-25 04:36 UTC Modified: 2004-05-26 19:24 UTC
From: john at odlin dot co dot uk Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.3.6 OS: Cobalt Linux
Private report: No CVE-ID: None
 [2004-05-25 04:36 UTC] john at odlin dot co dot uk
Description:
------------
POST variables don't get set if get called from a page that includes http:// in the action but GET works fine.

Apache/1.3.20 Sun Cobalt (Unix) mod_ssl/2.8.4 OpenSSL/0.9.6b PHP/4.3.6 mod_auth_pam_external/0.1 FrontPage/4.0.4.3 mod_perl/1.25 


using recommended ini file.

'./configure' '--prefix=/usr' '--with-apxs=/usr/sbin/apxs' '--with-gettext=/usr' '--with-config-file-path=/etc/httpd' '--with-exec-dir=/usr/bin' '--with-zlib' '--enable-magic-quotes' '--with-ttf' '--with-db' '--with-gdbm' '--enable-mbstring' '--enable-wddx=shared' '--enable-xml' '--enable-ftp' '--disable-debug' '--with-libdir=/usr/lib' '--with-pgsql=shared' '--with-pdflib=shared' '--enable-inline-optimization' '--with-openssl' '--enable-bcmath' '--enable-sockets' 


Reproduce code:
---------------
<FORM ACTION="" METHOD="POST">
<INPUT TYPE="TEXT" NAME="transId" VALUE="" SIZE="10">
<INPUT TYPE="SUBMIT" NAME="submit" VALUE="Submit">
</FORM>

<FORM ACTION="/index.php" METHOD="POST">
<INPUT TYPE="TEXT" NAME="transId" VALUE="" SIZE="10">
<INPUT TYPE="SUBMIT" NAME="submit" VALUE="Submit">
</FORM>

<FORM ACTION="http://www.domain.com/index.php" METHOD="POST">
<INPUT TYPE="TEXT" NAME="transId" VALUE="" SIZE="10">
<INPUT TYPE="SUBMIT" NAME="submit" VALUE="Submit">
</FORM>

The third example does not work.

Expected result:
----------------
Array
(
    [HTTP_POST_VARS] => Array
        (
            [transId] => 1
            [submit] => Submit
        )

    [_POST] => Array
        (
            [transId] => 1
            [submit] => Submit
        )

...


Actual result:
--------------
Array
(
    [HTTP_POST_VARS] => Array ( )

    [_POST] => Array ( )

...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-25 17:50 UTC] iliaa@php.net
What are the values or your gpc_order and variables_order 
INI settings? 
 [2004-05-25 21:36 UTC] john at odlin dot co dot uk
gpc_order GPC 
variables_order GPCS
 [2004-05-26 08:46 UTC] derick@php.net
AFAIK there were some problems with apache 1.3.20, please upgrade that to the latest version (1.3.29 iirc) and report back if that fixes the problem.
 [2004-05-26 19:06 UTC] john at odlin dot co dot uk
I cannot upgrade apache but it seems to be fixed in 4.3.7RC1
 [2004-05-26 19:24 UTC] iliaa@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

User reports that the issue is fixed in 4.3.7RC1. 
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 20 12:01:21 2019 UTC