php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28495 htmlentities() has no effect
Submitted: 2004-05-23 08:16 UTC Modified: 2004-05-24 01:52 UTC
From: hpaulit at arcor dot de Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 4.3.4 OS: Mac OS X 10.3/10.2
Private report: No CVE-ID: None
 [2004-05-23 08:16 UTC] hpaulit at arcor dot de
Description:
------------
I have a problem with the function htmlentities().

the function has no effect. Data in = Data out


Please Help me 

Reproduce code:
---------------
Here the listing:
<?php
$firma=" M?ller & M?der ";
echo "$firma without htmlentities<br>";
$firma=htmlentities($firma);
echo "$firma with htmlentities";
?>

Expected result:
----------------
output on the Website:
M?ller & M?der without htmlentities
M?ller & M?der with htmlentities - 

Output should be: M&uuml;ller &amp; M&auml;der



should be  M?ller & M?der on the website


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-23 15:39 UTC] moriyoshi@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Consult the relevant documentations at http://
www.php.net/docs

 [2004-05-24 01:52 UTC] hpaulit at arcor dot de
This is not a bug ? what else is a bug ?
I only want to get correct displayed names regardless 
wether solution make this.

$arg="M?ller & M?der";
$output=htmlentities($arg);

// $output as result per definition of function 
htmlentities() should be:

M&#252;ller &#38; M&#228;der

or

M&uuml;ller & M&auml;der 

and nothing else like

M?ller & M?der

Thank You 
Herbert Paulitsch
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 12:01:26 2018 UTC