php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28410 REQUEST_URI missing from $_SERVER in "require"d pages
Submitted: 2004-05-15 22:32 UTC Modified: 2004-05-16 16:22 UTC
From: fgasper at uiuc dot edu Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.3.6 OS: Windows Server 2003
Private report: No CVE-ID:
 [2004-05-15 22:32 UTC] fgasper at uiuc dot edu
Description:
------------
$_SERVER['REQUEST_URI'] is not defined.

Reproduce code:
---------------
<?php
print_r($_SERVER);
?>

Expected result:
----------------
REQUEST_URI should be in the output.

Actual result:
--------------
REQUEST_URI is not in the output.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-15 22:34 UTC] fgasper at uiuc dot edu
I'm using PHP as an ISAPI module.
 [2004-05-16 16:22 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This variable is not available because the IIS webserver 
does not provide it for PHP. 
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 00:02:04 2014 UTC